summaryrefslogtreecommitdiff
path: root/dev-ruby/puppetdb-termini/puppetdb-termini-7.4.1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-06-29 10:15:54 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-06-29 10:15:54 +0100
commit9aa80713372911cec499b3adb2cd746790920916 (patch)
treeb8e99dc5dd60ac2094a27cc52f74aada8df38f05 /dev-ruby/puppetdb-termini/puppetdb-termini-7.4.1.ebuild
parentb4d43e8c611df4a8061b6f88d9e9f6b1e3c83903 (diff)
gentoo resync : 29.06.2021
Diffstat (limited to 'dev-ruby/puppetdb-termini/puppetdb-termini-7.4.1.ebuild')
-rw-r--r--dev-ruby/puppetdb-termini/puppetdb-termini-7.4.1.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/dev-ruby/puppetdb-termini/puppetdb-termini-7.4.1.ebuild b/dev-ruby/puppetdb-termini/puppetdb-termini-7.4.1.ebuild
new file mode 100644
index 000000000000..57a8294eabe9
--- /dev/null
+++ b/dev-ruby/puppetdb-termini/puppetdb-termini-7.4.1.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+USE_RUBY="ruby23 ruby24 ruby25 ruby26"
+
+inherit unpacker
+
+DESCRIPTION="Library needed to connect puppet to puppetdb"
+HOMEPAGE="http://docs.puppetlabs.com/puppetdb/"
+SRC_URI="http://apt.puppetlabs.com/pool/stretch/puppet/${PN:0:1}/${PN}/${PN}_${PV}-1stretch_all.deb"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+IUSE=""
+# will need the same keywords as puppet
+KEYWORDS="~amd64 ~ppc ~x86"
+
+RDEPEND+=""
+DEPEND+=""
+
+S=${WORKDIR}
+
+src_install() {
+ insinto opt/puppetlabs/puppet/lib/ruby/vendor_ruby/puppet/
+ doins -r opt/puppetlabs/puppet/lib/ruby/vendor_ruby/puppet/*
+}