summaryrefslogtreecommitdiff
path: root/dev-ruby/pundit/pundit-2.2.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-04-06 22:33:41 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-04-06 22:33:41 +0100
commite68d405c5d712af4387159df07e226217bdda049 (patch)
tree009ab0f3d427f0813e62930d71802cb054c07e30 /dev-ruby/pundit/pundit-2.2.0.ebuild
parent401101f9c8077911929d3f2b60a37098460a5d89 (diff)
gentoo resync : 06.04.2022
Diffstat (limited to 'dev-ruby/pundit/pundit-2.2.0.ebuild')
-rw-r--r--dev-ruby/pundit/pundit-2.2.0.ebuild9
1 files changed, 6 insertions, 3 deletions
diff --git a/dev-ruby/pundit/pundit-2.2.0.ebuild b/dev-ruby/pundit/pundit-2.2.0.ebuild
index d4740a6fb537..db4c1e55370c 100644
--- a/dev-ruby/pundit/pundit-2.2.0.ebuild
+++ b/dev-ruby/pundit/pundit-2.2.0.ebuild
@@ -3,7 +3,7 @@
EAPI=8
-USE_RUBY="ruby26 ruby27"
+USE_RUBY="ruby26 ruby27 ruby30"
RUBY_FAKEGEM_RECIPE_TEST="rspec3"
@@ -19,8 +19,11 @@ IUSE=""
ruby_add_rdepend ">=dev-ruby/activesupport-3.0.0:*"
-ruby_add_bdepend "test? ( >=dev-ruby/actionpack-3.0.0
- >=dev-ruby/activemodel-3.0.0 )"
+ruby_add_bdepend "test? (
+ >=dev-ruby/actionpack-3.0.0
+ >=dev-ruby/activemodel-3.0.0
+ >=dev-ruby/railties-3.0.0
+)"
all_ruby_prepare() {
sed -i -e "/pry/d" -e '/simplecov/,/^end/ s:^:#:' spec/spec_helper.rb || die