summaryrefslogtreecommitdiff
path: root/dev-ruby/psych/psych-5.1.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-02-12 09:56:54 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-02-12 09:56:54 +0000
commitebc282ef4dfa408accac685565b8ee5f6faec119 (patch)
treec0a4f713228cda0ab17eed46f0bb7ca8cb8be2f6 /dev-ruby/psych/psych-5.1.0.ebuild
parent6c8694a707151d59555b0e4e48235f085ce166c3 (diff)
gentoo auto-resync : 12:02:2023 - 09:56:54
Diffstat (limited to 'dev-ruby/psych/psych-5.1.0.ebuild')
-rw-r--r--dev-ruby/psych/psych-5.1.0.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/dev-ruby/psych/psych-5.1.0.ebuild b/dev-ruby/psych/psych-5.1.0.ebuild
new file mode 100644
index 000000000000..4f5a5a2581c2
--- /dev/null
+++ b/dev-ruby/psych/psych-5.1.0.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+USE_RUBY="ruby27 ruby30 ruby31"
+
+RUBY_FAKEGEM_BINWRAP=""
+RUBY_FAKEGEM_EXTENSIONS=(ext/psych/extconf.rb)
+RUBY_FAKEGEM_EXTRADOC="README.md"
+
+inherit ruby-fakegem
+
+DESCRIPTION="A YAML parser and emitter"
+HOMEPAGE="https://github.com/ruby/psych"
+
+LICENSE="BSD-2"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~loong ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+SLOT="$(ver_cut 1)"
+IUSE="test"
+
+RDEPEND+=" >=dev-libs/libyaml-0.2.5"
+BDEPEND+=" >=dev-libs/libyaml-0.2.5"
+
+ruby_add_rdepend "dev-ruby/stringio"
+
+each_ruby_test() {
+ ${RUBY} -Ilib:.:test -e 'Dir["test/**/test_*.rb"].each{|f| require f}' || die
+}