summaryrefslogtreecommitdiff
path: root/dev-ruby/psych/psych-5.0.1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-12-11 09:22:24 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-12-11 09:22:24 +0000
commit583acea08c150460a36d3ee1a4800c33b9b19103 (patch)
tree9152116a16df0b23202b077b54a014f7d2c28373 /dev-ruby/psych/psych-5.0.1.ebuild
parentecd86b32a8f0b6be58bbb4b294ce38f1fbd7d3dc (diff)
gentoo auto-resync : 11:12:2022 - 09:22:24
Diffstat (limited to 'dev-ruby/psych/psych-5.0.1.ebuild')
-rw-r--r--dev-ruby/psych/psych-5.0.1.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/dev-ruby/psych/psych-5.0.1.ebuild b/dev-ruby/psych/psych-5.0.1.ebuild
new file mode 100644
index 000000000000..c79a5288fd87
--- /dev/null
+++ b/dev-ruby/psych/psych-5.0.1.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+USE_RUBY="ruby27 ruby30 ruby31"
+
+RUBY_FAKEGEM_BINWRAP=""
+RUBY_FAKEGEM_EXTENSIONS=(ext/psych/extconf.rb)
+RUBY_FAKEGEM_EXTRADOC="README.md"
+
+inherit ruby-fakegem
+
+DESCRIPTION="A YAML parser and emitter"
+HOMEPAGE="https://github.com/ruby/psych"
+
+LICENSE="BSD-2"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~loong ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+SLOT="$(ver_cut 1)"
+IUSE="test"
+
+RDEPEND+=" >=dev-libs/libyaml-0.2.5"
+BDEPEND+=" >=dev-libs/libyaml-0.2.5"
+
+ruby_add_rdepend "dev-ruby/stringio"
+
+each_ruby_test() {
+ ${RUBY} -Ilib:.:test -e 'Dir["test/**/test_*.rb"].each{|f| require f}' || die
+}