summaryrefslogtreecommitdiff
path: root/dev-ruby/protected_attributes
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-ruby/protected_attributes
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-ruby/protected_attributes')
-rw-r--r--dev-ruby/protected_attributes/Manifest3
-rw-r--r--dev-ruby/protected_attributes/metadata.xml11
-rw-r--r--dev-ruby/protected_attributes/protected_attributes-1.1.4.ebuild39
3 files changed, 53 insertions, 0 deletions
diff --git a/dev-ruby/protected_attributes/Manifest b/dev-ruby/protected_attributes/Manifest
new file mode 100644
index 000000000000..6efcd89b7be2
--- /dev/null
+++ b/dev-ruby/protected_attributes/Manifest
@@ -0,0 +1,3 @@
+DIST protected_attributes-1.1.4.tar.gz 23562 BLAKE2B 8b8c8a9f533344c6344de0e389807e39c06f53948d9206f965d0f954a9e8e8f4de61aebcbf96d95186b94e600ceceb48fd258087dfcc3baf15e65d588569829f SHA512 02c55825ec21dde386e31b25e71df4ac48c2356bad303a82cc33703b930c5f8e36b57193761dba59dff3868d39a3b5458fb2a2c49809019e72ed4b4f4313bed3
+EBUILD protected_attributes-1.1.4.ebuild 844 BLAKE2B 64ff73c83137b601f79425eaf6c6a32b71b8fc28b888cc3c1b23513aed8f2d5b3ed8bb50d53b524ddc7f2f115d1c5c66e91e20e42e597377c49b2ed2871b0352 SHA512 8491823b564d816be8f745f472e616399ffd723df1a044d0e48a8b63abe2e1cb4537c6735546af068bf2f4917dabf4787966fb162bb06f8503484c5d0a67dab9
+MISC metadata.xml 352 BLAKE2B c790bc4e8d646e1d3f14c8828332433d544d0b51331a3e42701679fd7796341bcd29c1d255916611ecde2ebf63d508c2a8494d2e9a46a99938f2c247d8bd0d74 SHA512 ec61fe67997d2f82c23e5746c2e1dc2176beb97b672d9d6ebfc68922e174f00c2a5867a7127feec9c65c7d93fbc8a3e167d7e574627ca6090b0cca5f5df26b4d
diff --git a/dev-ruby/protected_attributes/metadata.xml b/dev-ruby/protected_attributes/metadata.xml
new file mode 100644
index 000000000000..242f40c6e3a2
--- /dev/null
+++ b/dev-ruby/protected_attributes/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>ruby@gentoo.org</email>
+ <name>Gentoo Ruby Project</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">rails/protected_attributes</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-ruby/protected_attributes/protected_attributes-1.1.4.ebuild b/dev-ruby/protected_attributes/protected_attributes-1.1.4.ebuild
new file mode 100644
index 000000000000..e23b1df20ff0
--- /dev/null
+++ b/dev-ruby/protected_attributes/protected_attributes-1.1.4.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+USE_RUBY="ruby22 ruby23 ruby24"
+
+RUBY_FAKEGEM_TASK_TEST="test"
+
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG.md README.md"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Protect attributes from mass-assignment in ActiveRecord models"
+HOMEPAGE="https://github.com/rails/protected_attributes"
+SRC_URI="https://github.com/rails/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+SLOT="1"
+
+LICENSE="MIT"
+
+KEYWORDS="~amd64"
+IUSE="test"
+
+ruby_add_rdepend "
+ =dev-ruby/activemodel-4*:* >=dev-ruby/activemodel-4.0.1:*
+"
+
+ruby_add_bdepend "test? (
+ dev-ruby/bundler
+ =dev-ruby/actionpack-4*
+ =dev-ruby/activerecord-4*
+ =dev-ruby/rails-4*
+ dev-ruby/mocha
+ dev-ruby/sqlite3
+)"
+
+all_ruby_prepare() {
+ sed -i -e '/github/ s:^:#:' Gemfile || die
+}