summaryrefslogtreecommitdiff
path: root/dev-ruby/propshaft/propshaft-0.6.4.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-03-20 00:40:44 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-03-20 00:40:44 +0000
commit4cbcc855382a06088e2f016f62cafdbcb7e40665 (patch)
tree356496503d52354aa6d9f2d36126302fed5f3a73 /dev-ruby/propshaft/propshaft-0.6.4.ebuild
parentfcc5224904648a8e6eb528d7603154160a20022f (diff)
gentoo resync : 20.03.2022
Diffstat (limited to 'dev-ruby/propshaft/propshaft-0.6.4.ebuild')
-rw-r--r--dev-ruby/propshaft/propshaft-0.6.4.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/dev-ruby/propshaft/propshaft-0.6.4.ebuild b/dev-ruby/propshaft/propshaft-0.6.4.ebuild
new file mode 100644
index 000000000000..2573dcf1599e
--- /dev/null
+++ b/dev-ruby/propshaft/propshaft-0.6.4.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+USE_RUBY="ruby27"
+
+RUBY_FAKEGEM_BINWRAP=""
+RUBY_FAKEGEM_EXTRADOC="README.md"
+
+RUBY_FAKEGEM_GEMSPEC="propshaft.gemspec"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Deliver assets for Rails"
+HOMEPAGE="https://github.com/rails/propshaft"
+SRC_URI="https://github.com/rails/propshaft/archive/v${PV}.tar.gz -> ${P}-git.tgz"
+
+LICENSE="MIT"
+SLOT="$(ver_cut 1)"
+KEYWORDS="~amd64"
+
+IUSE=""
+
+ruby_add_rdepend "
+ >=dev-ruby/actionpack-7.0.0:*
+ >=dev-ruby/activesupport-7.0.0:*
+ dev-ruby/rack:*
+ >=dev-ruby/railties-7.0.0:*
+"
+
+ruby_add_bdepend "test? ( >=dev-ruby/rails-7.0.0 )"
+
+all_ruby_prepare() {
+ rm -f Gemfile.lock || die
+ sed -i -e '/debug/ s:^:#:' Gemfile || die
+
+ sed -i -e 's:_relative ": "./:' ${RUBY_FAKEGEM_GEMSPEC} || die
+}