summaryrefslogtreecommitdiff
path: root/dev-ruby/prawn-table/prawn-table-0.2.2-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /dev-ruby/prawn-table/prawn-table-0.2.2-r1.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'dev-ruby/prawn-table/prawn-table-0.2.2-r1.ebuild')
-rw-r--r--dev-ruby/prawn-table/prawn-table-0.2.2-r1.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/dev-ruby/prawn-table/prawn-table-0.2.2-r1.ebuild b/dev-ruby/prawn-table/prawn-table-0.2.2-r1.ebuild
new file mode 100644
index 000000000000..4f62d89b7409
--- /dev/null
+++ b/dev-ruby/prawn-table/prawn-table-0.2.2-r1.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+USE_RUBY="ruby21 ruby22 ruby23"
+
+RUBY_FAKEGEM_RECIPE_DOC="yard"
+RUBY_FAKEGEM_RECIPE_TEST="rspec"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Provides support for tables in Prawn"
+HOMEPAGE="http://prawn.majesticseacreature.com/"
+LICENSE="|| ( GPL-2+ Ruby )"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~x86"
+IUSE=""
+
+ruby_add_bdepend "test? ( dev-ruby/mocha
+ >=dev-ruby/pdf-inspector-1.1.0
+ >=dev-ruby/pdf-reader-1.2
+ >=dev-ruby/prawn-1.3.0
+ )"
+
+all_ruby_prepare() {
+ sed -i -e "/[Bb]undler/s/^/#/" spec/spec_helper.rb || die
+ # Remove failing test
+ # See https://github.com/prawnpdf/prawn-table/issues/10
+ sed -i -e "/Prints table on one page when using subtable with colspan > 1/,+24 s/^/#/" spec/table_spec.rb || die
+}