summaryrefslogtreecommitdiff
path: root/dev-ruby/postgres_ext
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-05-14 11:09:11 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-05-14 11:09:11 +0100
commitdeba8115d2c2af26df42966b91ef04ff4dd79cde (patch)
tree9a48f42594e1a9e6b2020d5535a784314434d7a7 /dev-ruby/postgres_ext
parent38423c67c8a23f6a1bc42038193182e2da3116eb (diff)
gentoo resync : 14.05.2020
Diffstat (limited to 'dev-ruby/postgres_ext')
-rw-r--r--dev-ruby/postgres_ext/Manifest3
-rw-r--r--dev-ruby/postgres_ext/metadata.xml11
-rw-r--r--dev-ruby/postgres_ext/postgres_ext-3.0.1.ebuild53
3 files changed, 0 insertions, 67 deletions
diff --git a/dev-ruby/postgres_ext/Manifest b/dev-ruby/postgres_ext/Manifest
deleted file mode 100644
index 239b00d97fd0..000000000000
--- a/dev-ruby/postgres_ext/Manifest
+++ /dev/null
@@ -1,3 +0,0 @@
-DIST postgres_ext-3.0.1.gem 24064 BLAKE2B 013a5b146474006f5bf15c5336b84b279a2d92afa632faa8e2c237f02bd4d899fb7ce7f7bda401df7b686ee7e952248db1278aeced9067a15343d13f5a5f832d SHA512 da1f47e90e12229f675955491d21eea56a349213db963e7a6e29886c1f5b8773a1988ca224be4abf5163e66e4189d98e9adf85d61e201488e5c13b36bc6f7b4f
-EBUILD postgres_ext-3.0.1.ebuild 1448 BLAKE2B 2bbe5af5da1795110bd86680e39e08959bb49c52e74ed75f53bd4e6d251e4161a7d2cd7539fe00098981fa843b3180007fa62133ade6e6be1cf71fab52fdca2d SHA512 9230f904c8d967cb6a084e7f177ed3fc45be38ea96d05029f9642bf3280b2f00dee5de6e80b9c3c99d63e11f22b89c2f051bcedae1b50bf2d12d2aeeb48b8531
-MISC metadata.xml 343 BLAKE2B d0e9097262d31b024b2c77f30e35d4d905b6dc9477f670e00d34bc7e60f54a5df408280bc65e168d4b9d0b37ef0e4f479aa485762d14952f7c13a2740548aa13 SHA512 b00bbf491b1dca98cdcbdd8a23982a5120205f07e9948c453c9c18ae3233e450cda7d6e78986b4a1b6ae17db15307ef9494be4e85aca31b453e3531ff0de060e
diff --git a/dev-ruby/postgres_ext/metadata.xml b/dev-ruby/postgres_ext/metadata.xml
deleted file mode 100644
index 3d9ac2a2fc57..000000000000
--- a/dev-ruby/postgres_ext/metadata.xml
+++ /dev/null
@@ -1,11 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
-<pkgmetadata>
- <maintainer type="person">
- <email>zerochaos@gentoo.org</email>
- <name>Rick Farina</name>
- </maintainer>
- <upstream>
- <remote-id type="github">dockyard/postgres_ext</remote-id>
- </upstream>
-</pkgmetadata>
diff --git a/dev-ruby/postgres_ext/postgres_ext-3.0.1.ebuild b/dev-ruby/postgres_ext/postgres_ext-3.0.1.ebuild
deleted file mode 100644
index 907385a5ddb1..000000000000
--- a/dev-ruby/postgres_ext/postgres_ext-3.0.1.ebuild
+++ /dev/null
@@ -1,53 +0,0 @@
-# Copyright 1999-2018 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-USE_RUBY="ruby22 ruby23 ruby24"
-
-RUBY_FAKEGEM_RECIPE_DOC="rdoc"
-
-inherit ruby-fakegem eapi7-ver
-
-DESCRIPTION="Native PostgreSQL data types and querying extensions for ActiveRecord and Arel"
-HOMEPAGE="https://github.com/dockyard/postgres_ext"
-
-LICENSE="BSD"
-SLOT="$(ver_cut 1)"
-KEYWORDS="~amd64 ~arm ~x86"
-IUSE=""
-
-# Requires live database connection
-RESTRICT=test
-
-ruby_add_rdepend "
- dev-ruby/activerecord:4.2
- >=dev-ruby/arel-4.0.1:*
- dev-ruby/pg_array_parser:0.0.9"
-
-ruby_add_bdepend "dev-ruby/bundler"
-
-all_ruby_prepare() {
- [ -f Gemfile.lock ] && rm Gemfile.lock
- #if ! use development; then
- sed -i -e "/^group :development do/,/^end$/d" Gemfile || die
- sed -i -e "/s.add_development_dependency/d" "${PN}".gemspec || die
- sed -i -e "/gem.add_development_dependency/d" "${PN}".gemspec || die
- #fi
- #if ! use test; then
- sed -i -e "/^group :test do/,/^end$/d" Gemfile || die
- #fi
- #if ! use test && ! use development; then
- sed -i -e "/^group :development, :test do/,/^end$/d" Gemfile || die
- #fi
- #https://github.com/dockyard/postgres_ext/issues/166
- #ugh, thanks
- sed -i -e "/byebug/d" Gemfile || die
- sed -i -e "/fivemat/d" Gemfile || die
-}
-
-each_ruby_prepare() {
- if [ -f Gemfile ]; then
- BUNDLE_GEMFILE=Gemfile ${RUBY} -S bundle install --local || die
- BUNDLE_GEMFILE=Gemfile ${RUBY} -S bundle check || die
- fi
-}