summaryrefslogtreecommitdiff
path: root/dev-ruby/postgres_ext
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-ruby/postgres_ext
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-ruby/postgres_ext')
-rw-r--r--dev-ruby/postgres_ext/Manifest3
-rw-r--r--dev-ruby/postgres_ext/metadata.xml11
-rw-r--r--dev-ruby/postgres_ext/postgres_ext-3.0.1.ebuild53
3 files changed, 67 insertions, 0 deletions
diff --git a/dev-ruby/postgres_ext/Manifest b/dev-ruby/postgres_ext/Manifest
new file mode 100644
index 000000000000..320a3694ef67
--- /dev/null
+++ b/dev-ruby/postgres_ext/Manifest
@@ -0,0 +1,3 @@
+DIST postgres_ext-3.0.1.gem 24064 BLAKE2B 013a5b146474006f5bf15c5336b84b279a2d92afa632faa8e2c237f02bd4d899fb7ce7f7bda401df7b686ee7e952248db1278aeced9067a15343d13f5a5f832d SHA512 da1f47e90e12229f675955491d21eea56a349213db963e7a6e29886c1f5b8773a1988ca224be4abf5163e66e4189d98e9adf85d61e201488e5c13b36bc6f7b4f
+EBUILD postgres_ext-3.0.1.ebuild 1468 BLAKE2B acb7bdbafe6d7e42345563058aadef2fca64abeed14cee3b65b8a3c7fc990b193cacff915fd49cdf7d069857bc31e85ef4e8c911571973185e7381081fe77e2f SHA512 e408fdacebe667d061cdf09376d6cf6feeaf8bb707302052a9bed9d86e8833de869b70b573568ccee7107f4aac618bac0f3b4dbed6570cdefed0923473ec5d82
+MISC metadata.xml 343 BLAKE2B d0e9097262d31b024b2c77f30e35d4d905b6dc9477f670e00d34bc7e60f54a5df408280bc65e168d4b9d0b37ef0e4f479aa485762d14952f7c13a2740548aa13 SHA512 b00bbf491b1dca98cdcbdd8a23982a5120205f07e9948c453c9c18ae3233e450cda7d6e78986b4a1b6ae17db15307ef9494be4e85aca31b453e3531ff0de060e
diff --git a/dev-ruby/postgres_ext/metadata.xml b/dev-ruby/postgres_ext/metadata.xml
new file mode 100644
index 000000000000..3d9ac2a2fc57
--- /dev/null
+++ b/dev-ruby/postgres_ext/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>zerochaos@gentoo.org</email>
+ <name>Rick Farina</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">dockyard/postgres_ext</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-ruby/postgres_ext/postgres_ext-3.0.1.ebuild b/dev-ruby/postgres_ext/postgres_ext-3.0.1.ebuild
new file mode 100644
index 000000000000..37ff049a3b7a
--- /dev/null
+++ b/dev-ruby/postgres_ext/postgres_ext-3.0.1.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+USE_RUBY="ruby22 ruby23 ruby24"
+
+RUBY_FAKEGEM_RECIPE_DOC="rdoc"
+
+inherit ruby-fakegem versionator
+
+DESCRIPTION="Native PostgreSQL data types and querying extensions for ActiveRecord and Arel"
+HOMEPAGE="https://github.com/dockyard/postgres_ext"
+
+LICENSE="BSD"
+SLOT="$(get_version_component_range 1)"
+KEYWORDS="~amd64 ~arm"
+IUSE=""
+
+# Requires live database connection
+RESTRICT=test
+
+ruby_add_rdepend "
+ dev-ruby/activerecord:4.2
+ >=dev-ruby/arel-4.0.1:*
+ dev-ruby/pg_array_parser:0.0.9"
+
+ruby_add_bdepend "dev-ruby/bundler"
+
+all_ruby_prepare() {
+ [ -f Gemfile.lock ] && rm Gemfile.lock
+ #if ! use development; then
+ sed -i -e "/^group :development do/,/^end$/d" Gemfile || die
+ sed -i -e "/s.add_development_dependency/d" "${PN}".gemspec || die
+ sed -i -e "/gem.add_development_dependency/d" "${PN}".gemspec || die
+ #fi
+ #if ! use test; then
+ sed -i -e "/^group :test do/,/^end$/d" Gemfile || die
+ #fi
+ #if ! use test && ! use development; then
+ sed -i -e "/^group :development, :test do/,/^end$/d" Gemfile || die
+ #fi
+ #https://github.com/dockyard/postgres_ext/issues/166
+ #ugh, thanks
+ sed -i -e "/byebug/d" Gemfile || die
+ sed -i -e "/fivemat/d" Gemfile || die
+}
+
+each_ruby_prepare() {
+ if [ -f Gemfile ]; then
+ BUNDLE_GEMFILE=Gemfile ${RUBY} -S bundle install --local || die
+ BUNDLE_GEMFILE=Gemfile ${RUBY} -S bundle check || die
+ fi
+}