summaryrefslogtreecommitdiff
path: root/dev-ruby/postgres_ext
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-04-19 14:14:48 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-04-19 14:14:48 +0100
commit5cfef3c94cd7e82136c69a0322f5ba21f7e64632 (patch)
tree8f255dfacbacb657e3ac3654d01c1e11e651c066 /dev-ruby/postgres_ext
parent8aebb228036d5e2863b7eaa6e319ab41c1669269 (diff)
gentoo resync : 19.04.2018
Diffstat (limited to 'dev-ruby/postgres_ext')
-rw-r--r--dev-ruby/postgres_ext/Manifest2
-rw-r--r--dev-ruby/postgres_ext/postgres_ext-3.0.1.ebuild53
2 files changed, 55 insertions, 0 deletions
diff --git a/dev-ruby/postgres_ext/Manifest b/dev-ruby/postgres_ext/Manifest
index b7422d0dda2d..765ae670e7f7 100644
--- a/dev-ruby/postgres_ext/Manifest
+++ b/dev-ruby/postgres_ext/Manifest
@@ -1,3 +1,5 @@
DIST postgres_ext-3.0.0.gem 21504 BLAKE2B 8fa38e78bd182e8c89746492d7082383b3411d987b95b6f01ca0fe961913aa74f3e32923150e3ce8d9dc0bf7377a65c6f2f926681b7dce0cf25873a8537c9ad0 SHA512 3d17a0f6ed98badf5c196ddc78e50d47c6a24edc19276f3939255f3d23490e30a3abc344da020d0480a8ec73586c6084349caf472f735461c4f9b6084d4d2c52
+DIST postgres_ext-3.0.1.gem 24064 BLAKE2B 013a5b146474006f5bf15c5336b84b279a2d92afa632faa8e2c237f02bd4d899fb7ce7f7bda401df7b686ee7e952248db1278aeced9067a15343d13f5a5f832d SHA512 da1f47e90e12229f675955491d21eea56a349213db963e7a6e29886c1f5b8773a1988ca224be4abf5163e66e4189d98e9adf85d61e201488e5c13b36bc6f7b4f
EBUILD postgres_ext-3.0.0.ebuild 1504 BLAKE2B 990944ea11fb8e783dcd1cab947c67440376581775d2e80f666321bf2afb44af0d132ac4e836a340e6528126a698a1fda54fe5ee7055eb020c4e94d7236a24eb SHA512 c51974d40c3e0623a7095e5d36bf635de1ae60de1729ff4a5e09f073344bc3e3ca57fd9e7f28a1da514e09fe5bfb2ba448a07d1dd782ee326457d68ef4cf3f28
+EBUILD postgres_ext-3.0.1.ebuild 1468 BLAKE2B acb7bdbafe6d7e42345563058aadef2fca64abeed14cee3b65b8a3c7fc990b193cacff915fd49cdf7d069857bc31e85ef4e8c911571973185e7381081fe77e2f SHA512 e408fdacebe667d061cdf09376d6cf6feeaf8bb707302052a9bed9d86e8833de869b70b573568ccee7107f4aac618bac0f3b4dbed6570cdefed0923473ec5d82
MISC metadata.xml 343 BLAKE2B d0e9097262d31b024b2c77f30e35d4d905b6dc9477f670e00d34bc7e60f54a5df408280bc65e168d4b9d0b37ef0e4f479aa485762d14952f7c13a2740548aa13 SHA512 b00bbf491b1dca98cdcbdd8a23982a5120205f07e9948c453c9c18ae3233e450cda7d6e78986b4a1b6ae17db15307ef9494be4e85aca31b453e3531ff0de060e
diff --git a/dev-ruby/postgres_ext/postgres_ext-3.0.1.ebuild b/dev-ruby/postgres_ext/postgres_ext-3.0.1.ebuild
new file mode 100644
index 000000000000..37ff049a3b7a
--- /dev/null
+++ b/dev-ruby/postgres_ext/postgres_ext-3.0.1.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+USE_RUBY="ruby22 ruby23 ruby24"
+
+RUBY_FAKEGEM_RECIPE_DOC="rdoc"
+
+inherit ruby-fakegem versionator
+
+DESCRIPTION="Native PostgreSQL data types and querying extensions for ActiveRecord and Arel"
+HOMEPAGE="https://github.com/dockyard/postgres_ext"
+
+LICENSE="BSD"
+SLOT="$(get_version_component_range 1)"
+KEYWORDS="~amd64 ~arm"
+IUSE=""
+
+# Requires live database connection
+RESTRICT=test
+
+ruby_add_rdepend "
+ dev-ruby/activerecord:4.2
+ >=dev-ruby/arel-4.0.1:*
+ dev-ruby/pg_array_parser:0.0.9"
+
+ruby_add_bdepend "dev-ruby/bundler"
+
+all_ruby_prepare() {
+ [ -f Gemfile.lock ] && rm Gemfile.lock
+ #if ! use development; then
+ sed -i -e "/^group :development do/,/^end$/d" Gemfile || die
+ sed -i -e "/s.add_development_dependency/d" "${PN}".gemspec || die
+ sed -i -e "/gem.add_development_dependency/d" "${PN}".gemspec || die
+ #fi
+ #if ! use test; then
+ sed -i -e "/^group :test do/,/^end$/d" Gemfile || die
+ #fi
+ #if ! use test && ! use development; then
+ sed -i -e "/^group :development, :test do/,/^end$/d" Gemfile || die
+ #fi
+ #https://github.com/dockyard/postgres_ext/issues/166
+ #ugh, thanks
+ sed -i -e "/byebug/d" Gemfile || die
+ sed -i -e "/fivemat/d" Gemfile || die
+}
+
+each_ruby_prepare() {
+ if [ -f Gemfile ]; then
+ BUNDLE_GEMFILE=Gemfile ${RUBY} -S bundle install --local || die
+ BUNDLE_GEMFILE=Gemfile ${RUBY} -S bundle check || die
+ fi
+}