summaryrefslogtreecommitdiff
path: root/dev-ruby/posix-spawn
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-06-16 05:02:38 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-06-16 05:02:38 +0100
commitf1bc537f089cc8477a9a18db597cb349e1b00e91 (patch)
treec48eb730c43e5f35729fabbe5cb4bfbe4a1bc794 /dev-ruby/posix-spawn
parentcb3e8c6af7661fbcafdcacc7e0ecdfb610d098fa (diff)
gentoo resync : 16.06.2018
Diffstat (limited to 'dev-ruby/posix-spawn')
-rw-r--r--dev-ruby/posix-spawn/Manifest2
-rw-r--r--dev-ruby/posix-spawn/files/posix-spawn-0.3.13-x86.patch23
-rw-r--r--dev-ruby/posix-spawn/posix-spawn-0.3.13-r1.ebuild37
3 files changed, 62 insertions, 0 deletions
diff --git a/dev-ruby/posix-spawn/Manifest b/dev-ruby/posix-spawn/Manifest
index 944bd0f0a231..37eab052f026 100644
--- a/dev-ruby/posix-spawn/Manifest
+++ b/dev-ruby/posix-spawn/Manifest
@@ -1,3 +1,5 @@
+AUX posix-spawn-0.3.13-x86.patch 713 BLAKE2B 0c10ac73b938fe985d6c3f3f084c4f96d19293610254029267cd5b16111acbb5792de7cc5dd5195f79d5f957206140bcc7a7c47b171bd565f9eee5350352bcb6 SHA512 33f5ee510fdeb7b8b150aa61e9d3044a1571470e1187d4dd0483e700c09bfb4bfba9a52c2cde723ed568ac3d2d1cb27855a4ef09826b902946138055d4b04774
DIST posix-spawn-0.3.13.gem 28160 BLAKE2B 68b1c241310c7b35bf8bea055e63a60320ae3fc877f9bc9f4e2dc0d30c1484eb5081be8c7d60309ed04900c410d52624dae6e37a0f134993f334526f2d9de98d SHA512 a9cd878571440cc0aaee541cbb97b6f4dcb03e48a8ef8588693f4c68990eb530e3b1685d615546763c9bba5d3109134442285023938eb2f116e9749f0da12bb9
+EBUILD posix-spawn-0.3.13-r1.ebuild 741 BLAKE2B b6d682b000542b2a1deb40e9d3d9397839bda09a4e44bcfa12ab8843f6335a605c240d8d7c22ca87b5cedf35ab63500fc834c022b1ae7e8405404c4754d91700 SHA512 b5dc9e969fc3f397abd3af513362d21c6b6a8bd3f7ca82f7c6f35292cc40cd9c4be7d30761f5509aa63b102e2c85b155d0ff5c89aab0b3b9e75b773e20dccc7d
EBUILD posix-spawn-0.3.13.ebuild 681 BLAKE2B e8c61d27ff00d42aca97ce70ff3e30a23fb073596bd02b4b3831ed84ec9003e80f3704908eeb563d551cc6575e92c348d40b801b710d49fbebde3ff36efc5f5d SHA512 489ecafe543fef55d3b819468e92e0b9dbd931461551ce686339187487d9ca325c1eb5ee584755b96f27f340b7c9f5f04ae018444b5254502eddfa2b577de906
MISC metadata.xml 346 BLAKE2B cb818c5b61108ddb5acfcf890d8ba737a8cc949fe607d02a5cc7dd1d264ecc7d73a096d8d40b65872fddb0791d63aefbdd774906da4b65122cd1087e040c4cd3 SHA512 208a7646bd550d2ecd50aecda3f1891b46cc586f74479eb6a72be27c985bf2ef1f411b609e54e73f418c1653a205e1ecedcfe3f2c2ebdb719e56c60f7b1b48a7
diff --git a/dev-ruby/posix-spawn/files/posix-spawn-0.3.13-x86.patch b/dev-ruby/posix-spawn/files/posix-spawn-0.3.13-x86.patch
new file mode 100644
index 000000000000..b96579b18281
--- /dev/null
+++ b/dev-ruby/posix-spawn/files/posix-spawn-0.3.13-x86.patch
@@ -0,0 +1,23 @@
+From 5201e921a788fbb97f14ea0c617a2213dc3da1ca Mon Sep 17 00:00:00 2001
+From: Pascal Terjan <pterjan@google.com>
+Date: Sun, 20 Aug 2017 12:13:15 +0100
+Subject: [PATCH] Fix build when SIZEOF_INT == SIZEOF_LONG
+
+Signed-off-by: Aman Gupta <aman@tmm1.net>
+---
+ ext/posix-spawn.c | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/ext/posix-spawn.c b/ext/posix-spawn.c
+index 1659bed..2e4c4de 100644
+--- a/ext/posix-spawn.c
++++ b/ext/posix-spawn.c
+@@ -61,7 +61,7 @@ posixspawn_obj_to_fd(VALUE obj)
+ * rb_fix2int takes care of raising if the provided object is a
+ * Bignum and is out of range of an int
+ */
+- fd = (int)rb_fix2int(obj);
++ fd = FIX2INT(obj);
+ break;
+
+ case T_SYMBOL:
diff --git a/dev-ruby/posix-spawn/posix-spawn-0.3.13-r1.ebuild b/dev-ruby/posix-spawn/posix-spawn-0.3.13-r1.ebuild
new file mode 100644
index 000000000000..eaea11a07923
--- /dev/null
+++ b/dev-ruby/posix-spawn/posix-spawn-0.3.13-r1.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+USE_RUBY="ruby23 ruby24 ruby25"
+
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_EXTRADOC="README.md TODO HACKING"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Library that implements a subset of the Ruby 1.9 Process::spawn"
+HOMEPAGE="https://github.com/rtomayko/posix-spawn/"
+
+KEYWORDS="~amd64 ~x86"
+
+LICENSE="MIT LGPL-2.1"
+SLOT="0"
+IUSE="test"
+
+all_ruby_prepare() {
+ eapply "${FILESDIR}/${P}-x86.patch"
+}
+
+each_ruby_configure() {
+ ${RUBY} -Cext extconf.rb || die
+}
+
+each_ruby_compile() {
+ emake V=1 -Cext
+ cp ext/*$(get_modname) lib/ || die
+}
+
+each_ruby_test() {
+ ${RUBY} -Ilib:.:test -e 'Dir["test/test_*.rb"].each {|f| require f}' || die
+}