summaryrefslogtreecommitdiff
path: root/dev-ruby/posix-spawn
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-05-30 11:44:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-05-30 11:44:06 +0100
commitf516638b7fe9592837389826a6152a7e1b251c54 (patch)
tree8bfecb640b7b6403d7a3d662d923eed630033da7 /dev-ruby/posix-spawn
parent1a61119f9f7b057830e2ce0563f913ec86f282ad (diff)
gentoo resync : 30.05.2020
Diffstat (limited to 'dev-ruby/posix-spawn')
-rw-r--r--dev-ruby/posix-spawn/Manifest2
-rw-r--r--dev-ruby/posix-spawn/posix-spawn-0.3.14.ebuild32
2 files changed, 34 insertions, 0 deletions
diff --git a/dev-ruby/posix-spawn/Manifest b/dev-ruby/posix-spawn/Manifest
index dee477fc8d34..8267c7a62bf0 100644
--- a/dev-ruby/posix-spawn/Manifest
+++ b/dev-ruby/posix-spawn/Manifest
@@ -1,4 +1,6 @@
AUX posix-spawn-0.3.13-x86.patch 713 BLAKE2B 0c10ac73b938fe985d6c3f3f084c4f96d19293610254029267cd5b16111acbb5792de7cc5dd5195f79d5f957206140bcc7a7c47b171bd565f9eee5350352bcb6 SHA512 33f5ee510fdeb7b8b150aa61e9d3044a1571470e1187d4dd0483e700c09bfb4bfba9a52c2cde723ed568ac3d2d1cb27855a4ef09826b902946138055d4b04774
DIST posix-spawn-0.3.13.gem 28160 BLAKE2B 68b1c241310c7b35bf8bea055e63a60320ae3fc877f9bc9f4e2dc0d30c1484eb5081be8c7d60309ed04900c410d52624dae6e37a0f134993f334526f2d9de98d SHA512 a9cd878571440cc0aaee541cbb97b6f4dcb03e48a8ef8588693f4c68990eb530e3b1685d615546763c9bba5d3109134442285023938eb2f116e9749f0da12bb9
+DIST posix-spawn-0.3.14.gem 29696 BLAKE2B 6c3cf234b8754b2757e0360f2b2bfd008628891ecec813dc3644f9a378317f3645908539588a3fbfae5a6fc4a0b9c5beb6fb925fdd9f6fb3cf8cdddbf6db448e SHA512 85d34d8301e1d0923831890d4ac3191e81cc4c716671bc3b71d44be92e9b0c278bd4ce17b9387fc10359266bbdee1e1aad5cb4bbf1c08ab385b023ba2fec74d7
EBUILD posix-spawn-0.3.13-r1.ebuild 757 BLAKE2B 0ac5fff7f8066b38d8b5cb159a0155513507043db4a6ccc401feacbd7444d8a14dc82102b26fd2485a0d31e24a2ed440d24a5e25542ebf725364d7fcd885374d SHA512 1eb99911823490208687dcc57be900bb922abe5f2fe212f4c9690937946be8d9160813301c5efc321bd13bf51dd353f41bada776057585cd54d85b9e72fab34e
+EBUILD posix-spawn-0.3.14.ebuild 671 BLAKE2B 26786957457f1d945c7c029db74f160fb737c35b315298d7708f5d5d14cd4b8b383a680070e63fa5e3c792babb2eba4771b065225f4199c7c995c7681ef802b8 SHA512 784460b55c349c87eaa75051ae67d75b7e1048d8e334daa8e498c7344942d1165f204fb628cccaa4fd1bd49746f2299eebf4b3bfb4dad07e7053bbd0f61e28dc
MISC metadata.xml 346 BLAKE2B cb818c5b61108ddb5acfcf890d8ba737a8cc949fe607d02a5cc7dd1d264ecc7d73a096d8d40b65872fddb0791d63aefbdd774906da4b65122cd1087e040c4cd3 SHA512 208a7646bd550d2ecd50aecda3f1891b46cc586f74479eb6a72be27c985bf2ef1f411b609e54e73f418c1653a205e1ecedcfe3f2c2ebdb719e56c60f7b1b48a7
diff --git a/dev-ruby/posix-spawn/posix-spawn-0.3.14.ebuild b/dev-ruby/posix-spawn/posix-spawn-0.3.14.ebuild
new file mode 100644
index 000000000000..d123fe204ec0
--- /dev/null
+++ b/dev-ruby/posix-spawn/posix-spawn-0.3.14.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+USE_RUBY="ruby24 ruby25 ruby26 ruby27"
+
+RUBY_FAKEGEM_EXTRADOC="README.md TODO HACKING"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Library that implements a subset of the Ruby 1.9 Process::spawn"
+HOMEPAGE="https://github.com/rtomayko/posix-spawn/"
+
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+
+LICENSE="MIT LGPL-2.1"
+SLOT="0"
+IUSE="test"
+
+each_ruby_configure() {
+ ${RUBY} -Cext extconf.rb || die
+}
+
+each_ruby_compile() {
+ emake V=1 -Cext
+ cp ext/*$(get_modname) lib/ || die
+}
+
+each_ruby_test() {
+ ${RUBY} -Ilib:.:test -e 'Dir["test/test_*.rb"].each {|f| require f}' || die
+}