summaryrefslogtreecommitdiff
path: root/dev-ruby/pkg-config/pkg-config-1.3.6.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-08-18 18:16:17 +0100
committerV3n3RiX <venerix@redcorelinux.org>2019-08-18 18:16:17 +0100
commitfc637fb28da700da71ec2064d65ca5a7a31b9c6c (patch)
tree326613a08f25851c388715e205576a2e7d25dc4f /dev-ruby/pkg-config/pkg-config-1.3.6.ebuild
parentb24bd25253fe093f722ab576d29fdc41d04cb1ee (diff)
gentoo resync : 18.08.2019
Diffstat (limited to 'dev-ruby/pkg-config/pkg-config-1.3.6.ebuild')
-rw-r--r--dev-ruby/pkg-config/pkg-config-1.3.6.ebuild33
1 files changed, 0 insertions, 33 deletions
diff --git a/dev-ruby/pkg-config/pkg-config-1.3.6.ebuild b/dev-ruby/pkg-config/pkg-config-1.3.6.ebuild
deleted file mode 100644
index 600fa391e78f..000000000000
--- a/dev-ruby/pkg-config/pkg-config-1.3.6.ebuild
+++ /dev/null
@@ -1,33 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-USE_RUBY="ruby23 ruby24 ruby25 ruby26"
-
-RUBY_FAKEGEM_EXTRADOC="README.rdoc NEWS"
-
-RUBY_FAKEGEM_TASK_DOC=""
-
-inherit ruby-fakegem
-
-DESCRIPTION="A pkg-config implementation by Ruby"
-HOMEPAGE="https://github.com/rcairo/pkg-config"
-LICENSE="|| ( LGPL-2 LGPL-2.1 LGPL-3 )"
-
-KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
-SLOT="0"
-IUSE="test"
-
-ruby_add_bdepend "test? ( >=dev-ruby/test-unit-2.5.1-r1 )"
-# this is used for testing
-DEPEND+=" test? ( x11-libs/cairo )"
-
-all_ruby_prepare() {
- # drop failing tests
- sed -i -e "/test_cflags/,/end/d"\
- -e "/test_cflags_only_I/,/end/d" test/test_pkg_config.rb || die
-}
-
-each_ruby_test() {
- ruby-ng_testrb-2 -Ilib test/test_${PN/-/_}.rb || die
-}