summaryrefslogtreecommitdiff
path: root/dev-ruby/pdf-core/pdf-core-0.8.1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-05-02 14:13:35 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-05-02 14:13:35 +0100
commit7c7c2c9727d6b2ff30945b5aea0d575e1c406d8b (patch)
treebac2a67fb24ac0836147fe370d30e1610ae1845d /dev-ruby/pdf-core/pdf-core-0.8.1.ebuild
parent2f8db31405fac68eea6f7257d58529243815033b (diff)
gentoo resync : 02.05.2018
Diffstat (limited to 'dev-ruby/pdf-core/pdf-core-0.8.1.ebuild')
-rw-r--r--dev-ruby/pdf-core/pdf-core-0.8.1.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/dev-ruby/pdf-core/pdf-core-0.8.1.ebuild b/dev-ruby/pdf-core/pdf-core-0.8.1.ebuild
new file mode 100644
index 000000000000..50cf1a76a97d
--- /dev/null
+++ b/dev-ruby/pdf-core/pdf-core-0.8.1.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+USE_RUBY="ruby23 ruby24"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec3"
+
+RUBY_FAKEGEM_RECIPE_DOC="rdoc"
+
+RUBY_FAKEGEM_GEMSPEC="${PN}.gemspec"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Implements low level PDF features for Prawn"
+HOMEPAGE="https://github.com/prawnpdf/pdf-core/"
+SRC_URI="https://github.com/prawnpdf/pdf-core/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="|| ( Ruby GPL-2 GPL-3 )"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="test"
+
+ruby_add_bdepend "test? ( =dev-ruby/pdf-inspector-1*
+ >=dev-ruby/pdf-reader-1.2 =dev-ruby/pdf-reader-1* )"
+
+all_ruby_prepare() {
+ sed -i -e "/[Bb]undler/d" spec/spec_helper.rb || die
+}