summaryrefslogtreecommitdiff
path: root/dev-ruby/patron
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-06-04 00:07:50 +0100
committerV3n3RiX <venerix@koprulu.sector>2024-06-04 00:07:50 +0100
commitdafa6f367240d1f5329ca89fb6f78985dbdc025b (patch)
tree96ba5ff3cc1d06604d928ca1b58ed15a4f8733dc /dev-ruby/patron
parenta3bb28551df94028000fb72308a9e9baa01458b0 (diff)
gentoo auto-resync : 04:06:2024 - 00:07:50
Diffstat (limited to 'dev-ruby/patron')
-rw-r--r--dev-ruby/patron/Manifest2
-rw-r--r--dev-ruby/patron/files/patron-0.13.3-fix-warning.patch24
-rw-r--r--dev-ruby/patron/patron-0.13.3-r3.ebuild45
3 files changed, 71 insertions, 0 deletions
diff --git a/dev-ruby/patron/Manifest b/dev-ruby/patron/Manifest
index 1c7bcc0f3665..93e9e8cd6c8a 100644
--- a/dev-ruby/patron/Manifest
+++ b/dev-ruby/patron/Manifest
@@ -1,3 +1,5 @@
+AUX patron-0.13.3-fix-warning.patch 747 BLAKE2B a486496bb438ef5ab294102d850c8e68fbd99442f58ddd00ce8ecfae9ae411d78fa40a229b51f3fc0a806542c95220fa953af3651744d3d0e9e560e6b71ce55a SHA512 c3d19f304b95f32b043458d34b7b14c5ad89035b4ab5585b8665229698e55379c551b0157b6ba69be81b273e537fcfde52c8fed57747edc23d54ab50ab443fcf
DIST patron-0.13.3.gem 65024 BLAKE2B 87aa69aab49978d14a80ed9e09d74d7853da3512875cc3aecd3f387d1523b85c84625b57a5826e5f5f999cec4feaae58c1aaae96582144a5c9dc537c9d5a4224 SHA512 afbbbd9570e338a5d1b97b4ebeda76ac95a22c29d908629723d345a47400183c2ccee67ebcaf5b6f9ecb032eb3b847e70ec9eebff75b33045a3665c215abfbd0
EBUILD patron-0.13.3-r2.ebuild 1119 BLAKE2B 4445953b2c88079755fb876ba5a529355fc38662b553ec8beff8b489ce845f01a2c9f05bcdfed2667baff61bc5d37fef74e313660373b94dd81e9a367e7ca19e SHA512 12d8b2079ce627dab7337669c7713ff7f826f4a64271472fdcc67f627ce98f4ba5972a22603e964dfd57e236c1d2594d5771342d5232c2413366474a6d9209ad
+EBUILD patron-0.13.3-r3.ebuild 1175 BLAKE2B 2fb3517c4ed478bfcdb534a49040e10fcc3b43d790198873318ff69be3ac2b1a3222f27c6c1dbf710933af8e48d818a65ee1ed86540509613447d2b24a240aeb SHA512 4862daa8493e18310c0add2c2973fd6a8a2b8b77c9e37f83fba8fa76f0756338f2568611d4df93d0387d2afd55d04cfc0020ecf406e67f1c6ecaef750628695d
MISC metadata.xml 324 BLAKE2B 80545356beebac06bf5b95f99be2f12fbb2fd4284e28036de156f75bef023216880bea03c9497123b0c111d4d37902b6ba3d9cab37ce5bc47b19e9d3e5e944f3 SHA512 1f260c57a3cce5424764eb1f287734d7e7093e08ffcdcac0c2f8ffe3c54a1aa53b21c008783b4a8b68bf20270d988b0ec108e9c647cafe347898a29d08b6a1ea
diff --git a/dev-ruby/patron/files/patron-0.13.3-fix-warning.patch b/dev-ruby/patron/files/patron-0.13.3-fix-warning.patch
new file mode 100644
index 000000000000..ff33cdcc287a
--- /dev/null
+++ b/dev-ruby/patron/files/patron-0.13.3-fix-warning.patch
@@ -0,0 +1,24 @@
+From 2b84ba489fb28f474195d215be7cc6bed43c32bc Mon Sep 17 00:00:00 2001
+From: Olle Jonsson <olle.jonsson@gmail.com>
+Date: Thu, 2 Apr 2020 21:02:51 +0200
+Subject: [PATCH] Avoid warning `*' interpreted as argument prefix
+
+---
+ lib/patron/request.rb | 4 ++--
+ 1 file changed, 2 insertions(+), 2 deletions(-)
+
+diff --git a/lib/patron/request.rb b/lib/patron/request.rb
+index 9050ef2..3ac998a 100644
+--- a/lib/patron/request.rb
++++ b/lib/patron/request.rb
+@@ -34,8 +34,8 @@ def initialize
+ :low_speed_time, :low_speed_limit, :progress_callback
+ ]
+
+- attr_reader *READER_VARS
+- attr_writer *WRITER_VARS
++ attr_reader(*READER_VARS)
++ attr_writer(*WRITER_VARS)
+
+ # Set the type of authentication to use for this request.
+ #
diff --git a/dev-ruby/patron/patron-0.13.3-r3.ebuild b/dev-ruby/patron/patron-0.13.3-r3.ebuild
new file mode 100644
index 000000000000..d09e7a4912f3
--- /dev/null
+++ b/dev-ruby/patron/patron-0.13.3-r3.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+USE_RUBY="ruby31 ruby32 ruby33"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec3"
+RUBY_FAKEGEM_EXTRADOC="README.md"
+
+RUBY_FAKEGEM_EXTENSIONS=(ext/patron/extconf.rb)
+RUBY_FAKEGEM_EXTENSION_DIR="lib/patron"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Patron is a Ruby HTTP client library based on libcurl"
+HOMEPAGE="https://github.com/toland/patron"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~x86"
+IUSE="test"
+
+DEPEND+=" net-misc/curl"
+RDEPEND+=" net-misc/curl"
+
+PATCHES=( "${FILESDIR}/${P}-fix-warning.patch" )
+
+ruby_add_bdepend "test? ( dev-ruby/rack:2.2 www-servers/puma )"
+
+all_ruby_prepare() {
+ # Fix Rakefile
+ sed -i -e 's:rake/rdoctask:rdoc/task:' \
+ -e 's/README.txt/README.md/' \
+ -e '/bundler/I s:^:#:' \
+ -e '/extensiontask/ s:^:#:' \
+ -e '/ExtensionTask/,/^end/ s:^:#:' \
+ Rakefile || die
+
+ # Avoid specs with failures. We were not running any specs before.
+ rm spec/session_ssl_spec.rb spec/session_spec.rb spec/response_spec.rb || die
+
+ # Ensure a compatible rack version
+ sed -i -e '1igem "rack", "~> 2.2.0"' spec/spec_helper.rb || die
+}