summaryrefslogtreecommitdiff
path: root/dev-ruby/pathutil/pathutil-0.16.2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-11-03 08:36:22 +0000
committerV3n3RiX <venerix@redcorelinux.org>2018-11-03 08:36:22 +0000
commitf65628136faa35d0c4d3b5e7332275c7b35fcd96 (patch)
tree021998302365c5652e37824b6c26d4d969a62055 /dev-ruby/pathutil/pathutil-0.16.2.ebuild
parent70b82ae359a5538711e103b0e8dfb92654296644 (diff)
gentoo resync : 03.11.2018
Diffstat (limited to 'dev-ruby/pathutil/pathutil-0.16.2.ebuild')
-rw-r--r--dev-ruby/pathutil/pathutil-0.16.2.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/dev-ruby/pathutil/pathutil-0.16.2.ebuild b/dev-ruby/pathutil/pathutil-0.16.2.ebuild
new file mode 100644
index 000000000000..de1ff3557b23
--- /dev/null
+++ b/dev-ruby/pathutil/pathutil-0.16.2.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+USE_RUBY="ruby23 ruby24 ruby25"
+
+RUBY_FAKEGEM_RECIPE_DOC="rdoc"
+RUBY_FAKEGEM_RECIPE_TEST="rspec3"
+
+RUBY_FAKEGEM_GEMSPEC="Gem.gemspec"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Like Pathname but a little less insane"
+HOMEPAGE="https://rubygems.org/gems/pathutil https://github.com/envygeeks/pathutils"
+SRC_URI="https://github.com/envygeeks/pathutil/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+ruby_add_rdepend ">=dev-ruby/forwardable-extended-2.6
+ <dev-ruby/forwardable-extended-3"
+
+all_ruby_prepare() {
+ sed -i -e '/\(coverage\|luna\|rspec\/helpers\)/ s:^:#:' \
+ -e '1irequire "pathname"; require "tempfile"; require "tmpdir"; require "json"' \
+ spec/rspec/helper.rb || die
+ rm -f spec/support/coverage.rb || die
+}