summaryrefslogtreecommitdiff
path: root/dev-ruby/pathutil/pathutil-0.16.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /dev-ruby/pathutil/pathutil-0.16.0.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'dev-ruby/pathutil/pathutil-0.16.0.ebuild')
-rw-r--r--dev-ruby/pathutil/pathutil-0.16.0.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/dev-ruby/pathutil/pathutil-0.16.0.ebuild b/dev-ruby/pathutil/pathutil-0.16.0.ebuild
new file mode 100644
index 000000000000..d6583688b0e3
--- /dev/null
+++ b/dev-ruby/pathutil/pathutil-0.16.0.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+USE_RUBY="ruby22 ruby23 ruby24"
+
+RUBY_FAKEGEM_RECIPE_DOC="rdoc"
+RUBY_FAKEGEM_RECIPE_TEST="rspec3"
+
+RUBY_FAKEGEM_GEMSPEC="Gem.gemspec"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Like Pathname but a little less insane"
+HOMEPAGE="https://rubygems.org/gems/pathutil https://github.com/envygeeks/pathutils"
+SRC_URI="https://github.com/envygeeks/pathutil/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+ruby_add_rdepend ">=dev-ruby/forwardable-extended-2.6
+ <dev-ruby/forwardable-extended-3"
+
+all_ruby_prepare() {
+ sed -i -e '/\(coverage\|luna\|rspec\/helpers\)/ s:^:#:' \
+ -e '1irequire "pathname"; require "tempfile"; require "tmpdir"; require "json"' \
+ spec/rspec/helper.rb || die
+ rm -f spec/support/coverage.rb || die
+}