summaryrefslogtreecommitdiff
path: root/dev-ruby/pairing_heap
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-02-13 11:36:00 +0000
committerV3n3RiX <venerix@koprulu.sector>2024-02-13 11:36:00 +0000
commitc06ab4b7bc60f01a7bd8c233ba4697157f30315f (patch)
tree85da2c94693d575c9324ab8f1616170ef5c928a9 /dev-ruby/pairing_heap
parent9e166f0fa8bc64fb267aaba88d9a55f8393e15a0 (diff)
gentoo auto-resync : 13:02:2024 - 11:36:00
Diffstat (limited to 'dev-ruby/pairing_heap')
-rw-r--r--dev-ruby/pairing_heap/Manifest2
-rw-r--r--dev-ruby/pairing_heap/pairing_heap-3.1.0.ebuild33
2 files changed, 35 insertions, 0 deletions
diff --git a/dev-ruby/pairing_heap/Manifest b/dev-ruby/pairing_heap/Manifest
index c11d5f74d0ff..26ddd69904d5 100644
--- a/dev-ruby/pairing_heap/Manifest
+++ b/dev-ruby/pairing_heap/Manifest
@@ -1,3 +1,5 @@
DIST pairing_heap-3.0.1.tar.gz 16965 BLAKE2B 80200dd98676c8ee9258ef96d296a4169b56d104875368bb8401b0f7d53494e3bbff8cfc5a536bdb24d844893ebe6962af709614b399c8c56980ee578ec2740b SHA512 0d22ccd42275aec54ff6960094c7ef14ad487835ba23217882a649c66585fc6c21af8a2f27f7a0a410fba6daf157ffdae6b74f1fdd798903ac597851945dee41
+DIST pairing_heap-3.1.0.tar.gz 17034 BLAKE2B 45d093df803b02109b2f8c339ac2f138606c3f2edf6c0430acedec0691c938d9bc38ff6c822267c7bceaa0ff9537070411db1ffba2c9565aaa7427a39d9b242e SHA512 b41f11d31c92bc9946bafe9d2be9d13df2cc3b67d7266e6bc7efa1c28c4a7a1ad6f4809070ba874594beb3146cc07a928034d29fd4247f139039bf03cf0c4809
EBUILD pairing_heap-3.0.1-r1.ebuild 914 BLAKE2B 29618ede7fc91f2d6d3ca9a1f74c5f2034a500b1e7d06b33d416e5d4d9fbc6a7f9629611be35449e862ad91fe88a163d8617bc1a9369d1ce1685c86c26167370 SHA512 10ab7611f439391d98a0fea013b713d593df40a7972a25988949867b33e1fcbeccb63a3aaa8dea8a1fc2681d14be3c537960f3e5f884c3dc7c2a8bd0e3b24b83
+EBUILD pairing_heap-3.1.0.ebuild 918 BLAKE2B e55799dabbe3076f32fa613c91ec7184c03d9b430bf49767d80b2cf437030b6b68fc07fccf6ecb5997733556b4a3675b9f67847f4da9b91f80ef7d868751577a SHA512 56f50b8d3bdc4502ee64bcb404cf8e8ab0d86d7b0d8962fd25249b499da499bddd7c4e03ef65b35ca1fd176be6d04d3798515cffd435b493e20471cfe4b24bbf
MISC metadata.xml 497 BLAKE2B 031d1ac42034e382202b0654788c13e078be09c082b5d1fe7099fcb5f93a0e53362f50180f73ee212e6b37d840968b3b2165c6270531b3cdde10b662f8574159 SHA512 cf96df8957624b2ba909ed222343e1fd74dafce6618fc4f7914afd841e2e425afd4609d841a4f876cdb24711187dbb8ebb12bd404a049833edcc7ad7eb6cb5e5
diff --git a/dev-ruby/pairing_heap/pairing_heap-3.1.0.ebuild b/dev-ruby/pairing_heap/pairing_heap-3.1.0.ebuild
new file mode 100644
index 000000000000..7bebc219b1bc
--- /dev/null
+++ b/dev-ruby/pairing_heap/pairing_heap-3.1.0.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+USE_RUBY="ruby31 ruby32"
+
+RUBY_FAKEGEM_BINWRAP=""
+RUBY_FAKEGEM_EXTRADOC="README.md"
+RUBY_FAKEGEM_GEMSPEC="pairing_heap.gemspec"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Performant priority queue with support for changing priority"
+HOMEPAGE="https://github.com/mhib/pairing_heap"
+SRC_URI="https://github.com/mhib/pairing_heap/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64"
+IUSE="test"
+
+# We normally patch out simplecov but the test suite does not work
+# correctly without it.
+ruby_add_bdepend "test? ( dev-ruby/minitest dev-ruby/simplecov )"
+
+all_ruby_prepare() {
+ sed -i -e '/require.*\(bundler\|standard\)/ s:^:#:' Rakefile || die
+
+ sed -e 's:_relative ": "./:' \
+ -e 's/__dir__/"."/' \
+ -e 's/git ls-files -z/find * -print0/' \
+ -i ${RUBY_FAKEGEM_GEMSPEC} || die
+}