summaryrefslogtreecommitdiff
path: root/dev-ruby/pairing_heap
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-08-18 21:36:58 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-08-18 21:36:58 +0100
commitea4d97bae88695501ff5f5c646a57e2e0488e423 (patch)
treeafc4100ae641b360049e5bc3a2e1cc4c408641bb /dev-ruby/pairing_heap
parenta2f7cdda45fadf1f967379421e8d808b1a503cd3 (diff)
gentoo auto-resync : 18:08:2023 - 21:36:58
Diffstat (limited to 'dev-ruby/pairing_heap')
-rw-r--r--dev-ruby/pairing_heap/Manifest3
-rw-r--r--dev-ruby/pairing_heap/metadata.xml14
-rw-r--r--dev-ruby/pairing_heap/pairing_heap-3.0.1.ebuild31
3 files changed, 48 insertions, 0 deletions
diff --git a/dev-ruby/pairing_heap/Manifest b/dev-ruby/pairing_heap/Manifest
new file mode 100644
index 000000000000..7632bd9b9cb5
--- /dev/null
+++ b/dev-ruby/pairing_heap/Manifest
@@ -0,0 +1,3 @@
+DIST pairing_heap-3.0.1.tar.gz 16965 BLAKE2B 80200dd98676c8ee9258ef96d296a4169b56d104875368bb8401b0f7d53494e3bbff8cfc5a536bdb24d844893ebe6962af709614b399c8c56980ee578ec2740b SHA512 0d22ccd42275aec54ff6960094c7ef14ad487835ba23217882a649c66585fc6c21af8a2f27f7a0a410fba6daf157ffdae6b74f1fdd798903ac597851945dee41
+EBUILD pairing_heap-3.0.1.ebuild 804 BLAKE2B 0993ee44ecefa94b6ef13c0fc9b43cf5b91b15f11c8e815f0375c4506dd8bed2a55bf1d171ce79fe4e1b7cb667b5f04718137ec3800db3978614013bbff08983 SHA512 068cf89a0bd93b44391f1bd5e40b10642f0ddfc8bf9fc1c99180500452151beec0e6ccc0d4a92c40b20fa826b6615f531dafbeac2d488e6fe31d39595ce032b6
+MISC metadata.xml 497 BLAKE2B 031d1ac42034e382202b0654788c13e078be09c082b5d1fe7099fcb5f93a0e53362f50180f73ee212e6b37d840968b3b2165c6270531b3cdde10b662f8574159 SHA512 cf96df8957624b2ba909ed222343e1fd74dafce6618fc4f7914afd841e2e425afd4609d841a4f876cdb24711187dbb8ebb12bd404a049833edcc7ad7eb6cb5e5
diff --git a/dev-ruby/pairing_heap/metadata.xml b/dev-ruby/pairing_heap/metadata.xml
new file mode 100644
index 000000000000..dfe26ba04abc
--- /dev/null
+++ b/dev-ruby/pairing_heap/metadata.xml
@@ -0,0 +1,14 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>ruby@gentoo.org</email>
+ <name>Gentoo Ruby Project</name>
+ </maintainer>
+ <longdescription>
+ Performant priority queue in pure ruby with support for changing priority using pairing heap data structure
+ </longdescription>
+ <upstream>
+ <remote-id type="github">mhib/pairing_heap</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-ruby/pairing_heap/pairing_heap-3.0.1.ebuild b/dev-ruby/pairing_heap/pairing_heap-3.0.1.ebuild
new file mode 100644
index 000000000000..81b8a228b8ab
--- /dev/null
+++ b/dev-ruby/pairing_heap/pairing_heap-3.0.1.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+USE_RUBY="ruby30 ruby31 ruby32"
+
+RUBY_FAKEGEM_BINWRAP=""
+RUBY_FAKEGEM_EXTRADOC="README.md"
+RUBY_FAKEGEM_GEMSPEC="pairing_heap.gemspec"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Performant priority queue with support for changing priority"
+HOMEPAGE="https://github.com/mhib/pairing_heap"
+SRC_URI="https://github.com/mhib/pairing_heap/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+ruby_add_bdepend "test? ( dev-ruby/minitest )"
+
+all_ruby_prepare() {
+ sed -i -e '/require.*\(bundler\|standard\)/ s:^:#:' Rakefile || die
+
+ sed -e 's:_relative ": "./:' \
+ -e 's/__dir__/"."/' \
+ -e 's/git ls-files -z/find * -print0/' \
+ -i ${RUBY_FAKEGEM_GEMSPEC} || die
+}