summaryrefslogtreecommitdiff
path: root/dev-ruby/pairing_heap
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-09-10 16:36:07 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-09-10 16:36:07 +0100
commitd0041c590ed45bbfeae458ea926e36bc64e41dd7 (patch)
tree9f8a3bcf226736635a558a6d70fcd46b60f90a17 /dev-ruby/pairing_heap
parent5067796b074450a155155c782ef4885c885cfb2b (diff)
gentoo auto-resync : 10:09:2023 - 16:36:07
Diffstat (limited to 'dev-ruby/pairing_heap')
-rw-r--r--dev-ruby/pairing_heap/Manifest1
-rw-r--r--dev-ruby/pairing_heap/pairing_heap-3.0.1-r1.ebuild33
2 files changed, 34 insertions, 0 deletions
diff --git a/dev-ruby/pairing_heap/Manifest b/dev-ruby/pairing_heap/Manifest
index d5c51a58bb82..6fe0853c7726 100644
--- a/dev-ruby/pairing_heap/Manifest
+++ b/dev-ruby/pairing_heap/Manifest
@@ -1,3 +1,4 @@
DIST pairing_heap-3.0.1.tar.gz 16965 BLAKE2B 80200dd98676c8ee9258ef96d296a4169b56d104875368bb8401b0f7d53494e3bbff8cfc5a536bdb24d844893ebe6962af709614b399c8c56980ee578ec2740b SHA512 0d22ccd42275aec54ff6960094c7ef14ad487835ba23217882a649c66585fc6c21af8a2f27f7a0a410fba6daf157ffdae6b74f1fdd798903ac597851945dee41
+EBUILD pairing_heap-3.0.1-r1.ebuild 914 BLAKE2B 29618ede7fc91f2d6d3ca9a1f74c5f2034a500b1e7d06b33d416e5d4d9fbc6a7f9629611be35449e862ad91fe88a163d8617bc1a9369d1ce1685c86c26167370 SHA512 10ab7611f439391d98a0fea013b713d593df40a7972a25988949867b33e1fcbeccb63a3aaa8dea8a1fc2681d14be3c537960f3e5f884c3dc7c2a8bd0e3b24b83
EBUILD pairing_heap-3.0.1.ebuild 811 BLAKE2B 168d36e10ebc5497f5e35b9689126a5533c23e096ad24d9862696cab17ea9c35bf1b67c0ced55f897ce7e56cefaf88825f221a853acafcafa9f1d022420ae182 SHA512 cece03ffeba711f1163b591843a1d2d5fd409414c283dcdd707e00855fe676dada29e00b748a0af49d383f5303d2686c8fab5eca20a17d33ef935956a5c170a9
MISC metadata.xml 497 BLAKE2B 031d1ac42034e382202b0654788c13e078be09c082b5d1fe7099fcb5f93a0e53362f50180f73ee212e6b37d840968b3b2165c6270531b3cdde10b662f8574159 SHA512 cf96df8957624b2ba909ed222343e1fd74dafce6618fc4f7914afd841e2e425afd4609d841a4f876cdb24711187dbb8ebb12bd404a049833edcc7ad7eb6cb5e5
diff --git a/dev-ruby/pairing_heap/pairing_heap-3.0.1-r1.ebuild b/dev-ruby/pairing_heap/pairing_heap-3.0.1-r1.ebuild
new file mode 100644
index 000000000000..9e71f07dc62b
--- /dev/null
+++ b/dev-ruby/pairing_heap/pairing_heap-3.0.1-r1.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+USE_RUBY="ruby31 ruby32"
+
+RUBY_FAKEGEM_BINWRAP=""
+RUBY_FAKEGEM_EXTRADOC="README.md"
+RUBY_FAKEGEM_GEMSPEC="pairing_heap.gemspec"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Performant priority queue with support for changing priority"
+HOMEPAGE="https://github.com/mhib/pairing_heap"
+SRC_URI="https://github.com/mhib/pairing_heap/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64"
+IUSE=""
+
+# We normally patch out simplecov but the test suite does not work
+# correctly without it.
+ruby_add_bdepend "test? ( dev-ruby/minitest dev-ruby/simplecov )"
+
+all_ruby_prepare() {
+ sed -i -e '/require.*\(bundler\|standard\)/ s:^:#:' Rakefile || die
+
+ sed -e 's:_relative ": "./:' \
+ -e 's/__dir__/"."/' \
+ -e 's/git ls-files -z/find * -print0/' \
+ -i ${RUBY_FAKEGEM_GEMSPEC} || die
+}