summaryrefslogtreecommitdiff
path: root/dev-ruby/ox/ox-2.9.2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-04-28 20:02:04 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-04-28 20:02:04 +0100
commita4e2a46beb5e4858ef27bdedbb0ff6d2ced430ad (patch)
tree852c90a4bf354c30ea66504f70bfab5401fba18d /dev-ruby/ox/ox-2.9.2.ebuild
parent5e8702bcbbed438e6c6cce023e7ef0cc9baa3e02 (diff)
gentoo resync : 28.04.2018
Diffstat (limited to 'dev-ruby/ox/ox-2.9.2.ebuild')
-rw-r--r--dev-ruby/ox/ox-2.9.2.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/dev-ruby/ox/ox-2.9.2.ebuild b/dev-ruby/ox/ox-2.9.2.ebuild
new file mode 100644
index 000000000000..f03cb3bed818
--- /dev/null
+++ b/dev-ruby/ox/ox-2.9.2.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+USE_RUBY="ruby23 ruby24 ruby25"
+
+RUBY_FAKEGEM_EXTRADOC="README.md"
+RUBY_FAKEGEM_RECIPE_DOC="rdoc"
+
+inherit ruby-fakegem
+
+DESCRIPTION="A fast XML parser and Object marshaller"
+HOMEPAGE="http://www.ohler.com/ox/ https://github.com/ohler55/ox"
+SRC_URI="https://github.com/ohler55/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+LICENSE="BSD"
+
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+SLOT="0"
+IUSE=""
+
+each_ruby_configure() {
+ ${RUBY} -Cext/ox extconf.rb || die
+}
+
+each_ruby_compile() {
+ emake V=1 -Cext/ox
+ cp ext/ox/ox$(get_modname) lib/ox/ || die
+}
+
+each_ruby_test() {
+ ${RUBY} test/tests.rb || die
+}