summaryrefslogtreecommitdiff
path: root/dev-ruby/optimist
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-03-19 11:37:34 +0000
committerV3n3RiX <venerix@redcorelinux.org>2019-03-19 11:37:34 +0000
commitb7b97785ebbb2f11d24d14dab8b81ed274f4ce6a (patch)
tree9fd110f9fc996e8a4213eeda994a8c112491b86d /dev-ruby/optimist
parent066d27181e9a797ad9f8fc43b49fc9a10ff2f707 (diff)
gentoo resync : 19.03.2019
Diffstat (limited to 'dev-ruby/optimist')
-rw-r--r--dev-ruby/optimist/Manifest3
-rw-r--r--dev-ruby/optimist/metadata.xml15
-rw-r--r--dev-ruby/optimist/optimist-3.0.0.ebuild29
3 files changed, 47 insertions, 0 deletions
diff --git a/dev-ruby/optimist/Manifest b/dev-ruby/optimist/Manifest
new file mode 100644
index 000000000000..720ae46edbee
--- /dev/null
+++ b/dev-ruby/optimist/Manifest
@@ -0,0 +1,3 @@
+DIST optimist-3.0.0.gem 29696 BLAKE2B d078a21fc95d64827e3f9a4539339ba3e3ba9f9649cb70d4e5a830f2523b02c4bb6aa1dca159a913d852aa2a320002beb6276d920ae1804bf65c9cf1535fc341 SHA512 1fcdc4dd01fb26d5b1d181913ad28314df05e60277bcf73b98e04a7463430a6c73396fb729e3cf34bc89e2eb8387d4d3294e93fcd530129a7bcd7efdcef5223f
+EBUILD optimist-3.0.0.ebuild 771 BLAKE2B 5ec2c548abb422434f2fa61f35a98262073b03c9ca43427e79114289fc2f40144c834443cb7291d8340ff5b5b7563a8ac41cbd45481e41eacca7a1218077c380 SHA512 916d15295b0ced1ef22d9ea2176407ededf63d56fe0f82a7850092a7cf62847dd017eab718267997e2e31b588ef9d17b5b2918c928cbfc229468066bcdf23dae
+MISC metadata.xml 615 BLAKE2B a53d6689cb0a71ffe1bcd34437e4213114da2c79857404d084e55079125d8890d758b77f889dd9223b15f75b0cb286ae6b675d70938d901078d90072bc7fce20 SHA512 b0cedf05cb559e4673164d64d39a3523dae4bb27b33b1114bcc98da5ed550a752dae52f0882f66fd0d3a4cad1bab9619de6b3dea3148518eacb3046fa4022863
diff --git a/dev-ruby/optimist/metadata.xml b/dev-ruby/optimist/metadata.xml
new file mode 100644
index 000000000000..5e9369be77e1
--- /dev/null
+++ b/dev-ruby/optimist/metadata.xml
@@ -0,0 +1,15 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>ruby@gentoo.org</email>
+ <name>Gentoo Ruby Project</name>
+ </maintainer>
+ <longdescription>
+ Optimist is a commandline option parser for Ruby that just gets
+ out of your way. One line of code per option is all you need to
+ write. For that, you get a nice automatically-generated help page,
+ robust option parsing, command subcompletion, and sensible
+ defaults for everything you don't specify.
+ </longdescription>
+</pkgmetadata>
diff --git a/dev-ruby/optimist/optimist-3.0.0.ebuild b/dev-ruby/optimist/optimist-3.0.0.ebuild
new file mode 100644
index 000000000000..2da197f04833
--- /dev/null
+++ b/dev-ruby/optimist/optimist-3.0.0.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+USE_RUBY="ruby23 ruby24 ruby25 ruby26"
+
+RUBY_FAKEGEM_RECIPE_DOC="rdoc"
+RUBY_FAKEGEM_EXTRADOC="FAQ.txt History.txt README.md"
+
+inherit ruby-fakegem
+
+DESCRIPTION="A commandline option parser for Ruby that just gets out of your way."
+HOMEPAGE="https://manageiq.github.io/optimist/"
+LICENSE="MIT"
+
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+SLOT="3"
+IUSE=""
+
+ruby_add_bdepend "test? ( dev-ruby/chronic )"
+
+all_ruby_prepare() {
+ sed -i -e '/bundle/ s:^:#:' Rakefile || die
+}
+
+each_ruby_test() {
+ MUTANT=true ${RUBY} -S rake test || die "Tests failed."
+}