summaryrefslogtreecommitdiff
path: root/dev-ruby/optimist/optimist-3.0.1-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-06-20 07:15:41 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-06-20 07:15:41 +0100
commit7d1fc8f13082082c2539f20beadcf37089543b8e (patch)
treefda7c412f8ace82836e911da18f1b0f6eaf8bc55 /dev-ruby/optimist/optimist-3.0.1-r1.ebuild
parentbc4457d8e0e53a2e43c4254d08053ba9708663e1 (diff)
gentoo auto-resync : 20:06:2023 - 07:15:40
Diffstat (limited to 'dev-ruby/optimist/optimist-3.0.1-r1.ebuild')
-rw-r--r--dev-ruby/optimist/optimist-3.0.1-r1.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/dev-ruby/optimist/optimist-3.0.1-r1.ebuild b/dev-ruby/optimist/optimist-3.0.1-r1.ebuild
new file mode 100644
index 000000000000..1abe03c9e1f4
--- /dev/null
+++ b/dev-ruby/optimist/optimist-3.0.1-r1.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+USE_RUBY="ruby30 ruby31 ruby32"
+
+RUBY_FAKEGEM_EXTRADOC="FAQ.txt History.txt README.md"
+
+inherit ruby-fakegem
+
+DESCRIPTION="A commandline option parser for Ruby that just gets out of your way"
+HOMEPAGE="https://www.manageiq.org/optimist/"
+LICENSE="MIT"
+
+KEYWORDS="~amd64 ~arm64 ~hppa ~ppc ~ppc64 ~sparc ~x86 ~ppc-macos ~x64-macos ~x64-solaris"
+SLOT="3"
+IUSE=""
+
+ruby_add_bdepend "test? ( dev-ruby/chronic )"
+
+all_ruby_prepare() {
+ sed -i -e '/bundle/ s:^:#:' Rakefile || die
+}
+
+each_ruby_test() {
+ MUTANT=true ${RUBY} -S rake test || die "Tests failed."
+}