summaryrefslogtreecommitdiff
path: root/dev-ruby/octokit/octokit-4.14.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-04-05 21:17:31 +0100
committerV3n3RiX <venerix@redcorelinux.org>2019-04-05 21:17:31 +0100
commitdc7cbdfa65fd814b3b9aa3c56257da201109e807 (patch)
treec85d72f6f31f21f178069c9d41d41a7c1ff4b362 /dev-ruby/octokit/octokit-4.14.0.ebuild
parent0706fc6986773f4e4d391deff4ad5143c464ea4e (diff)
gentoo resync : 05.04.2019
Diffstat (limited to 'dev-ruby/octokit/octokit-4.14.0.ebuild')
-rw-r--r--dev-ruby/octokit/octokit-4.14.0.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/dev-ruby/octokit/octokit-4.14.0.ebuild b/dev-ruby/octokit/octokit-4.14.0.ebuild
new file mode 100644
index 000000000000..e4f7af55045e
--- /dev/null
+++ b/dev-ruby/octokit/octokit-4.14.0.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+USE_RUBY="ruby23 ruby24"
+
+RUBY_FAKEGEM_RECIPE_DOC="yard"
+RUBY_FAKEGEM_RECIPE_TEST="rspec3"
+RUBY_FAKEGEM_EXTRADOC="README.md CONTRIBUTING.md"
+RUBY_FAKEGEM_GEMSPEC="${PN}.gemspec"
+
+inherit multilib ruby-fakegem
+
+DESCRIPTION="Ruby toolkit for the Github API"
+HOMEPAGE="https://github.com/octokit/octokit.rb"
+SRC_URI="https://github.com/octokit/octokit.rb/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE=""
+
+RUBY_S=octokit.rb-${PV}
+
+ruby_add_rdepend ">=dev-ruby/sawyer-0.8.0"
+ruby_add_bdepend "test? ( dev-ruby/mime-types
+ >=dev-ruby/netrc-0.7.7
+ dev-ruby/vcr:3
+ dev-ruby/webmock:3 )"
+
+all_ruby_prepare() {
+ sed -i -e '/if RUBY_ENGINE/,/^end/ s:^:#: ; 1igem "webmock", "~>3.0"' spec/helper.rb || die
+}