summaryrefslogtreecommitdiff
path: root/dev-ruby/oauth/oauth-0.5.10.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-03-31 04:04:12 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-03-31 04:04:12 +0100
commit15d97fe857a00a52fd4efb0a31ed0560f9de3a24 (patch)
treefff97afa4cdc01dee4972402cf810f00aaec487a /dev-ruby/oauth/oauth-0.5.10.ebuild
parented6e9ebb6ab4abd792d5b15e97ec245603dd6e2d (diff)
gentoo auto-resync : 31:03:2023 - 04:04:12
Diffstat (limited to 'dev-ruby/oauth/oauth-0.5.10.ebuild')
-rw-r--r--dev-ruby/oauth/oauth-0.5.10.ebuild45
1 files changed, 0 insertions, 45 deletions
diff --git a/dev-ruby/oauth/oauth-0.5.10.ebuild b/dev-ruby/oauth/oauth-0.5.10.ebuild
deleted file mode 100644
index d2a781ddc4e8..000000000000
--- a/dev-ruby/oauth/oauth-0.5.10.ebuild
+++ /dev/null
@@ -1,45 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-USE_RUBY="ruby26 ruby27 ruby30"
-
-RUBY_FAKEGEM_EXTRADOC="CHANGELOG.md README.md TODO"
-
-RUBY_FAKEGEM_GEMSPEC="oauth.gemspec"
-
-inherit ruby-fakegem
-
-DESCRIPTION="A RubyGem for implementing both OAuth clients and servers"
-HOMEPAGE="https://github.com/oauth-xx/oauth-ruby"
-SRC_URI="https://github.com/oauth-xx/oauth-ruby/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-RUBY_S="${PN}-ruby-${PV}"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64 ~ppc ~riscv ~x86"
-IUSE=""
-
-ruby_add_bdepend "test? (
- dev-ruby/bundler
- dev-ruby/test-unit:2
- dev-ruby/mocha:1.0
- dev-ruby/webmock
- dev-ruby/rack
- dev-ruby/actionpack:6.1
- dev-ruby/railties:6.1
-)"
-
-all_ruby_prepare() {
- # Require a compatible version of mocha
- sed -i -e '1igem "mocha", "~> 1.0"; gem "railties", "~>6.1.0" ; gem "actionpack", "~>6.1.0"; require "action_dispatch"' \
- -e '/mocha/ s/mini_test/minitest/' \
- -e '/\(byebug\|minitest_helpers\|simplecov\)/I s:^:#:' test/test_helper.rb || die
-
- # Avoid test tripped up by kwargs confusion
- sed -i -e '/test_authorize/askip "kwargs confusion"' test/units/test_cli.rb || die
-}
-
-each_ruby_test() {
- ${RUBY} -Ilib:test:. -e 'Dir["test/**/*test*.rb"].each {|f| require f}' || die
-}