summaryrefslogtreecommitdiff
path: root/dev-ruby/ntlm-http/ntlm-http-0.1.1-r3.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2021-12-05 02:47:11 +0000
committerV3n3RiX <venerix@koprulu.sector>2021-12-05 02:47:11 +0000
commit2771f79232c273bc2a57d23bf335dd81ccf6af28 (patch)
treec8af0fd04194aed03cf067d44e53c7edd3e9ab84 /dev-ruby/ntlm-http/ntlm-http-0.1.1-r3.ebuild
parente9d044d4b9b71200a96adfa280848858c0f468c9 (diff)
gentoo resync : 05.12.2021
Diffstat (limited to 'dev-ruby/ntlm-http/ntlm-http-0.1.1-r3.ebuild')
-rw-r--r--dev-ruby/ntlm-http/ntlm-http-0.1.1-r3.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/dev-ruby/ntlm-http/ntlm-http-0.1.1-r3.ebuild b/dev-ruby/ntlm-http/ntlm-http-0.1.1-r3.ebuild
new file mode 100644
index 000000000000..960bd91a5093
--- /dev/null
+++ b/dev-ruby/ntlm-http/ntlm-http-0.1.1-r3.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+USE_RUBY="ruby26 ruby27"
+
+RUBY_FAKEGEM_RECIPE_TEST="none"
+
+RUBY_FAKEGEM_DOC_SOURCES="lib README"
+RUBY_FAKEGEM_EXTRADOC="README"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Ruby/NTLM HTTP provides NTLM authentication over http"
+HOMEPAGE="http://www.mindflowsolutions.net/"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-solaris"
+IUSE="test"
+
+ruby_add_bdepend "test? ( >=dev-ruby/test-unit-2.5.1-r1 )"
+
+all_ruby_prepare() {
+ find . -name '*.rb' -exec sed -i -e 's:\r$::' {} +
+
+ # We can't use RUBY_PATCHES for this because we need first to convert the files
+ eapply "${FILESDIR}"/${P}+ruby-1.9.patch
+}
+
+each_ruby_test() {
+ ruby-ng_testrb-2 test/*_test.rb
+}