summaryrefslogtreecommitdiff
path: root/dev-ruby/nio4r/nio4r-2.0.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-04-22 14:25:03 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-04-22 14:25:03 +0100
commit5e8702bcbbed438e6c6cce023e7ef0cc9baa3e02 (patch)
treeb041acef19bb9ae66c228d5c9d34d1e00aeb2b95 /dev-ruby/nio4r/nio4r-2.0.0.ebuild
parent5cfef3c94cd7e82136c69a0322f5ba21f7e64632 (diff)
gentoo resync : 22.04.2018
Diffstat (limited to 'dev-ruby/nio4r/nio4r-2.0.0.ebuild')
-rw-r--r--dev-ruby/nio4r/nio4r-2.0.0.ebuild38
1 files changed, 0 insertions, 38 deletions
diff --git a/dev-ruby/nio4r/nio4r-2.0.0.ebuild b/dev-ruby/nio4r/nio4r-2.0.0.ebuild
deleted file mode 100644
index 337aeed28b2e..000000000000
--- a/dev-ruby/nio4r/nio4r-2.0.0.ebuild
+++ /dev/null
@@ -1,38 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-USE_RUBY="ruby22 ruby23"
-
-RUBY_FAKEGEM_RECIPE_TEST="rspec3"
-
-RUBY_FAKEGEM_TASK_DOC=""
-RUBY_FAKEGEM_EXTRADOC="CHANGES.md README.md"
-
-inherit ruby-fakegem
-
-DESCRIPTION="A high performance selector API for monitoring IO objects"
-HOMEPAGE="https://github.com/celluloid/nio4r"
-
-LICENSE="MIT"
-SLOT="2"
-KEYWORDS="~amd64 ~arm ~ppc64 ~x86 ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
-IUSE=""
-
-# Note that nio4r bundles a patched copy of libev, and without these
-# patches the tests fail: https://github.com/celluloid/nio4r/issues/15
-
-all_ruby_prepare() {
- sed -i -e '/[Cc]overalls/d' -e '/[Bb]undler/d' spec/spec_helper.rb || die
- sed -e '/extension/ s:^:#:' -i Rakefile || die
-}
-
-each_ruby_configure() {
- ${RUBY} -Cext/${PN} extconf.rb || die
-}
-
-each_ruby_compile() {
- emake V=1 -Cext/${PN}
- cp ext/${PN}/*$(get_modname) lib/ || die
-}