summaryrefslogtreecommitdiff
path: root/dev-ruby/network_interface/network_interface-0.0.1-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-02-11 16:09:52 +0000
committerV3n3RiX <venerix@redcorelinux.org>2018-02-11 16:09:52 +0000
commitf78108598211053d41752a83e0345441bb9014ae (patch)
treedd2fc7ae0a1aea7bda4942ab0c453d1e55284b37 /dev-ruby/network_interface/network_interface-0.0.1-r1.ebuild
parentdc45b83b28fb83e9659492066e347b8dc60bc9e3 (diff)
gentoo resync : 11.02.2018
Diffstat (limited to 'dev-ruby/network_interface/network_interface-0.0.1-r1.ebuild')
-rw-r--r--dev-ruby/network_interface/network_interface-0.0.1-r1.ebuild36
1 files changed, 0 insertions, 36 deletions
diff --git a/dev-ruby/network_interface/network_interface-0.0.1-r1.ebuild b/dev-ruby/network_interface/network_interface-0.0.1-r1.ebuild
deleted file mode 100644
index fd106305983a..000000000000
--- a/dev-ruby/network_interface/network_interface-0.0.1-r1.ebuild
+++ /dev/null
@@ -1,36 +0,0 @@
-# Copyright 1999-2016 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-USE_RUBY="ruby20 ruby21 ruby22 ruby23"
-
-RUBY_FAKEGEM_TASK_DOC=""
-
-RUBY_FAKEGEM_RECIPE_TEST="rspec"
-
-inherit ruby-fakegem
-
-DESCRIPTION="network_interface layer from metasploit pcaprub"
-HOMEPAGE="https://github.com/rapid7/network_interface"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64 ~arm ~x86"
-IUSE=""
-
-# Tests are brittle as they cannot deal with all network interface configurations.
-RESTRICT="test"
-
-all_ruby_prepare() {
- sed -i -e 's:/sbin/ifconfig:/bin/ifconfig:' spec/spec_helper.rb || die
-}
-
-each_ruby_configure() {
- ${RUBY} -C ext/network_interface_ext extconf.rb || die
-}
-
-each_ruby_compile() {
- emake -C ext/network_interface_ext V=1
- cp ext/network_interface_ext/network_interface_ext.so lib/ || die
-}