summaryrefslogtreecommitdiff
path: root/dev-ruby/net-http-pipeline/net-http-pipeline-1.0.1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /dev-ruby/net-http-pipeline/net-http-pipeline-1.0.1.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'dev-ruby/net-http-pipeline/net-http-pipeline-1.0.1.ebuild')
-rw-r--r--dev-ruby/net-http-pipeline/net-http-pipeline-1.0.1.ebuild23
1 files changed, 23 insertions, 0 deletions
diff --git a/dev-ruby/net-http-pipeline/net-http-pipeline-1.0.1.ebuild b/dev-ruby/net-http-pipeline/net-http-pipeline-1.0.1.ebuild
new file mode 100644
index 000000000000..e1b3a1c05690
--- /dev/null
+++ b/dev-ruby/net-http-pipeline/net-http-pipeline-1.0.1.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+USE_RUBY="ruby21 ruby22 ruby23 ruby24"
+RUBY_FAKEGEM_RECIPE_DOC="rdoc"
+
+inherit ruby-fakegem
+
+DESCRIPTION="An HTTP/1.1 pipelining implementation atop Net::HTTP"
+HOMEPAGE="http://docs.seattlerb.org/net-http-pipeline/"
+
+LICENSE="MIT"
+SLOT="1"
+KEYWORDS="~amd64"
+IUSE=""
+
+RUBY_PATCHES=( ${PN}-accept-encoding.patch )
+
+ruby_add_bdepend "
+ dev-ruby/hoe
+ test? ( dev-ruby/minitest )
+"