summaryrefslogtreecommitdiff
path: root/dev-ruby/net-http-persistent/net-http-persistent-3.1.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-03-29 21:54:14 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-03-29 21:54:14 +0100
commit911d13b08c9edf41dd5fd5f5e15c952ca1fc3b6c (patch)
tree98c9e54e57ca3eaa2b64cf2002fb8fc5a11620dd /dev-ruby/net-http-persistent/net-http-persistent-3.1.0.ebuild
parent822a054dd1bab7f8080ccd486398034b4ff0b97d (diff)
gentoo auto-resync : 29:03:2023 - 21:54:14
Diffstat (limited to 'dev-ruby/net-http-persistent/net-http-persistent-3.1.0.ebuild')
-rw-r--r--dev-ruby/net-http-persistent/net-http-persistent-3.1.0.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/dev-ruby/net-http-persistent/net-http-persistent-3.1.0.ebuild b/dev-ruby/net-http-persistent/net-http-persistent-3.1.0.ebuild
new file mode 100644
index 000000000000..13fed6f70af6
--- /dev/null
+++ b/dev-ruby/net-http-persistent/net-http-persistent-3.1.0.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+USE_RUBY="ruby25 ruby26 ruby27"
+
+RUBY_FAKEGEM_RECIPE_DOC="rdoc"
+
+RUBY_FAKEGEM_EXTRADOC="History.txt README.rdoc"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Manages persistent connections using Net::HTTP plus a speed fix for Ruby 1.8"
+HOMEPAGE="https://github.com/drbrain/net-http-persistent"
+
+LICENSE="MIT"
+SLOT="3"
+KEYWORDS="amd64 ~arm ~ppc ~ppc64 x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-solaris"
+IUSE="doc test"
+
+ruby_add_rdepend ">=dev-ruby/connection_pool-2.2:0"
+
+ruby_add_bdepend "
+ test? ( dev-ruby/hoe dev-ruby/minitest )"
+
+all_ruby_prepare() {
+ # avoid test with implicit dependency on net-http-pipeline which
+ # fails and is not tested upstream
+ sed -i -e '/net-http-pipeline not installed/ s/unless.*$//' test/test_net_http_persistent.rb || die
+}