summaryrefslogtreecommitdiff
path: root/dev-ruby/naught
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-ruby/naught
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-ruby/naught')
-rw-r--r--dev-ruby/naught/Manifest3
-rw-r--r--dev-ruby/naught/metadata.xml11
-rw-r--r--dev-ruby/naught/naught-1.1.0.ebuild24
3 files changed, 38 insertions, 0 deletions
diff --git a/dev-ruby/naught/Manifest b/dev-ruby/naught/Manifest
new file mode 100644
index 000000000000..2407f15ae2f4
--- /dev/null
+++ b/dev-ruby/naught/Manifest
@@ -0,0 +1,3 @@
+DIST naught-1.1.0.gem 19456 BLAKE2B 175611b8653966500ef7cd963b8c9bd895f82e72af87b0f3358b74b91e5915dccf4da76fc916e30214d6f45ee3c84f232f83cf04afef3fa5c7b1283614c41339 SHA512 0a25825df0234f15a53dc7a8dff546846c605fde9b1e3ce0b3e88f6e1753117bd48586b450dcd08c45a0d4877a04ac19feb98fd70d929f9da3ccba8478e46a57
+EBUILD naught-1.1.0.ebuild 530 BLAKE2B b62542e91fe0f031c2f6b7a1e456add6a137c1b2a5adf943d68ff60c854ce3862c00985a97c074303c4cf652195f12b9cb92951d8c9f80c1f01f975c372915ec SHA512 e6787186a88288295f03c35a69e2c634d0f95cb6f4626d6cde3b7d86f3591a4f103e3c093575c532ac6a9403fdf0dbc3c11e68833c160399eb7864aa11d119ed
+MISC metadata.xml 337 BLAKE2B dda79776fac9433189a64de181525b4a007093c91323e10b91c085858b0741df09aad1a6c36e475d21b79466ff31dff9e357eecf57d4540097a841dfb0c41b1e SHA512 5feb819a51001368e45b98e730144a64de0a774e15f2967b7284d25d6d748a51c47caadec2800ffe9fc1c1e20598eb17aa5bf159901bb799b8c10cb4598cf0b6
diff --git a/dev-ruby/naught/metadata.xml b/dev-ruby/naught/metadata.xml
new file mode 100644
index 000000000000..84250ba2ce52
--- /dev/null
+++ b/dev-ruby/naught/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>ruby@gentoo.org</email>
+ <name>Gentoo Ruby Project</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">avdi/naught</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-ruby/naught/naught-1.1.0.ebuild b/dev-ruby/naught/naught-1.1.0.ebuild
new file mode 100644
index 000000000000..1dd68bddc319
--- /dev/null
+++ b/dev-ruby/naught/naught-1.1.0.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+USE_RUBY="ruby23 ruby24 ruby25"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec3"
+
+RUBY_FAKEGEM_RECIPE_DOC="rdoc"
+RUBY_FAKEGEM_EXTRADOC="Changelog.md README.markdown"
+
+inherit ruby-fakegem
+
+DESCRIPTION="A toolkit for building Null Objects in Ruby"
+HOMEPAGE="https://github.com/avdi/naught"
+
+LICENSE="MIT"
+SLOT="5"
+KEYWORDS="~amd64"
+IUSE=""
+
+all_ruby_prepare() {
+ sed -i -e '/simplecov/,/^end/ s:^:#:' spec/spec_helper.rb || die
+}