summaryrefslogtreecommitdiff
path: root/dev-ruby/mustache/mustache-1.0.2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /dev-ruby/mustache/mustache-1.0.2.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'dev-ruby/mustache/mustache-1.0.2.ebuild')
-rw-r--r--dev-ruby/mustache/mustache-1.0.2.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/dev-ruby/mustache/mustache-1.0.2.ebuild b/dev-ruby/mustache/mustache-1.0.2.ebuild
new file mode 100644
index 000000000000..69205abcb67a
--- /dev/null
+++ b/dev-ruby/mustache/mustache-1.0.2.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+USE_RUBY="ruby20 ruby21 ruby22 ruby23"
+
+RUBY_FAKEGEM_TASK_TEST=""
+
+RUBY_FAKEGEM_TASK_DOC="man:build"
+RUBY_FAKEGEM_EXTRADOC="README.md"
+
+inherit multilib ruby-fakegem
+
+DESCRIPTION="Mustache is a framework-agnostic way to render logic-free views"
+HOMEPAGE="https://mustache.github.com/"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="alpha amd64 arm hppa ia64 ppc ppc64 ~sparc x86 ~x86-fbsd"
+IUSE=""
+
+ruby_add_bdepend "doc? ( app-text/ronn )"
+
+all_ruby_prepare() {
+ # Fix rake deprecation
+ sed -i -e 's:rake/rdoctask:rdoc/task:' Rakefile || die
+
+ # Avoid code climate dependency.
+ sed -i -e '/codeclimate/I s:^:#:' test/helper.rb || die
+}
+
+each_ruby_test() {
+ ${RUBY} -Ilib:. -e "Dir['test/*.rb'].each{|f| require f}" || die
+}
+
+all_ruby_install() {
+ all_fakegem_install
+
+ doman man/mustache.1 man/mustache.5
+}