summaryrefslogtreecommitdiff
path: root/dev-ruby/msgpack
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-ruby/msgpack
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-ruby/msgpack')
-rw-r--r--dev-ruby/msgpack/Manifest5
-rw-r--r--dev-ruby/msgpack/metadata.xml11
-rw-r--r--dev-ruby/msgpack/msgpack-1.2.2.ebuild44
-rw-r--r--dev-ruby/msgpack/msgpack-1.2.4.ebuild42
4 files changed, 102 insertions, 0 deletions
diff --git a/dev-ruby/msgpack/Manifest b/dev-ruby/msgpack/Manifest
new file mode 100644
index 000000000000..38a094deeaa3
--- /dev/null
+++ b/dev-ruby/msgpack/Manifest
@@ -0,0 +1,5 @@
+DIST msgpack-1.2.2.gem 78848 BLAKE2B b3ae75ebd6159a78c6a31ecc45bfe0474d5fe91672b6c9dfe96a561b07ebb5bc9ebf91477bc370fba199c5a8c187faa4995a90aa0209b8af81e6d06cd2e58b7b SHA512 7f7fa3350485c3888a42a78fc53f91029208bc6ee483b4c1a082dfa515d435295b6d2f57e9c4cc3f7805349e4a21854585997075d2535c0343af4ae1ec66a802
+DIST msgpack-1.2.4.gem 78848 BLAKE2B 5e4c0f75e051bd1da800257600a44a712a18430b77b1c6ceebf1b6452bda0169fa7fdbd3dc5230b76da226965b32e1581ab3c27be8416c00bd90e827b22bce51 SHA512 dc2267a8c2f673ce6c8910e09841ec01bd84f06baf68b9c9ba2c0acb905d197ca82f481748ceb7edb7dff5359c4d983f381882923a1d935bd5bc536bd2fa60be
+EBUILD msgpack-1.2.2.ebuild 1134 BLAKE2B c96c7d377e63ae95ffd1916ba016489b38c9c34387fc5b9dd52a9730e633f3b3b661f1d8d8b21f7f66fcd962a525d8ecb28ec6af509e44a0605eba96d5231601 SHA512 2345264a73acd9e213d5dc5d62843b83e06bc6d813bd843519b1483366c0a42c3168997329d71b90304f9d2d67f53ef74196ba6525a9b9d0247a10c66820476a
+EBUILD msgpack-1.2.4.ebuild 1101 BLAKE2B 0582ac0dea935e463e500f1a164a40e185df13360197aafd89b374c08adfde0c84854fbfb543bbd870d4cfe5b80a55e1069f271dab42024721cb9f3fd5e5772b SHA512 fae3728d285f338c8b00d6f4765ccfca17c8bcbe298352ebe05b2b1115fb1cd5eac15d0d51140d81e29c6d20a59e8ba14f8454cd45fbbdae5d8f8c9d287effc7
+MISC metadata.xml 331 BLAKE2B c964da6cce4e1e413377a6bf37282aa6ba207c33f3682ca5738361bb0df8c45dec063abe22f3183354b79b70707f897382a3412de1f6b185460a26ac2006f082 SHA512 5cff44a3b9425bbdccb3b682a26355c9526931b2826d7ff91da0d6db5e0dd139ae556a47dd06757b5cd209413b67181483189ba2dae819f70ffa58a46751c4c0
diff --git a/dev-ruby/msgpack/metadata.xml b/dev-ruby/msgpack/metadata.xml
new file mode 100644
index 000000000000..6c33329090c7
--- /dev/null
+++ b/dev-ruby/msgpack/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>ruby@gentoo.org</email>
+ <name>Gentoo Ruby Project</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="sourceforge-jp">msgpack</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-ruby/msgpack/msgpack-1.2.2.ebuild b/dev-ruby/msgpack/msgpack-1.2.2.ebuild
new file mode 100644
index 000000000000..ea2b33ee6acc
--- /dev/null
+++ b/dev-ruby/msgpack/msgpack-1.2.2.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+USE_RUBY="ruby22 ruby23 ruby24"
+
+RUBY_FAKEGEM_TASK_DOC="doc"
+RUBY_FAKEGEM_RECIPE_TEST="rspec3"
+RUBY_FAKEGEM_EXTRADOC="README.rdoc"
+
+inherit multilib ruby-fakegem
+
+DESCRIPTION="Binary-based efficient data interchange format for ruby binding"
+HOMEPAGE="https://msgpack.org/"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ppc64 ~x86 ~x86-fbsd"
+IUSE="doc"
+
+ruby_add_bdepend "doc? ( dev-ruby/yard )"
+
+all_ruby_prepare() {
+ sed -i -e '/bundler/I s:^:#:' Rakefile || die
+
+ # Remove jruby-specific specs that are run also for other rubies.
+ rm -rf spec/jruby || die
+
+ sed -i -e '/git ls-files/d' msgpack.gemspec || die
+}
+
+each_ruby_configure() {
+ ${RUBY} -Cext/${PN} extconf.rb || die "Configuration of extension failed."
+
+ # rb_num2int is not inlined on 32 bit arches but also not explicitly
+ # defined, bug 582968
+ sed -i -e 's:-Wl,--no-undefined::' ext/${PN}/Makefile || die
+}
+
+each_ruby_compile() {
+ emake V=1 -Cext/${PN}
+ cp ext/${PN}/msgpack$(get_modname) lib/${PN} || die "Unable to install msgpack library."
+}
diff --git a/dev-ruby/msgpack/msgpack-1.2.4.ebuild b/dev-ruby/msgpack/msgpack-1.2.4.ebuild
new file mode 100644
index 000000000000..280a20307332
--- /dev/null
+++ b/dev-ruby/msgpack/msgpack-1.2.4.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+USE_RUBY="ruby22 ruby23 ruby24 ruby25"
+
+RUBY_FAKEGEM_RECIPE_DOC="rdoc"
+RUBY_FAKEGEM_RECIPE_TEST="rspec3"
+RUBY_FAKEGEM_EXTRADOC="README.rdoc"
+
+inherit multilib ruby-fakegem
+
+DESCRIPTION="Binary-based efficient data interchange format for ruby binding"
+HOMEPAGE="https://msgpack.org/"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ppc64 ~x86 ~x86-fbsd"
+IUSE="doc"
+
+all_ruby_prepare() {
+ sed -i -e '/bundler/I s:^:#:' Rakefile || die
+
+ # Remove jruby-specific specs that are run also for other rubies.
+ rm -rf spec/jruby || die
+
+ sed -i -e '/git ls-files/d' msgpack.gemspec || die
+}
+
+each_ruby_configure() {
+ ${RUBY} -Cext/${PN} extconf.rb || die "Configuration of extension failed."
+
+ # rb_num2int is not inlined on 32 bit arches but also not explicitly
+ # defined, bug 582968
+ sed -i -e 's:-Wl,--no-undefined::' ext/${PN}/Makefile || die
+}
+
+each_ruby_compile() {
+ emake V=1 -Cext/${PN}
+ cp ext/${PN}/msgpack$(get_modname) lib/${PN} || die "Unable to install msgpack library."
+}