summaryrefslogtreecommitdiff
path: root/dev-ruby/msgpack/msgpack-1.7.2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-07-19 07:03:48 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-07-19 07:03:48 +0100
commit5c9d85c89af4d9d7228124d3d0bcdd14a9aba91a (patch)
tree833dda1f349e37f3992b6235aa33bee330949943 /dev-ruby/msgpack/msgpack-1.7.2.ebuild
parentd59dfc99c5c30e62ba4cc55c9eae72aab4a930bf (diff)
gentoo auto-resync : 19:07:2023 - 07:03:47
Diffstat (limited to 'dev-ruby/msgpack/msgpack-1.7.2.ebuild')
-rw-r--r--dev-ruby/msgpack/msgpack-1.7.2.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/dev-ruby/msgpack/msgpack-1.7.2.ebuild b/dev-ruby/msgpack/msgpack-1.7.2.ebuild
new file mode 100644
index 000000000000..8126b1988a4b
--- /dev/null
+++ b/dev-ruby/msgpack/msgpack-1.7.2.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+USE_RUBY="ruby30 ruby31 ruby32"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec3"
+RUBY_FAKEGEM_EXTRADOC="ChangeLog README.md"
+RUBY_FAKEGEM_BINWRAP=""
+RUBY_FAKEGEM_EXTENSIONS=(ext/msgpack/extconf.rb)
+RUBY_FAKEGEM_EXTENSION_LIBDIR="lib/msgpack"
+RUBY_FAKEGEM_GEMSPEC="${PN}.gemspec"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Binary-based efficient data interchange format for ruby binding"
+HOMEPAGE="https://msgpack.org/"
+SRC_URI="https://github.com/msgpack/msgpack-ruby/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
+RUBY_S="${PN}-ruby-${PV}"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ppc64 ~sparc ~x86"
+IUSE="doc"
+
+all_ruby_prepare() {
+ sed -i -e '/bundler/I s:^:#:' Rakefile || die
+
+ # Remove jruby-specific specs that are run also for other rubies.
+ rm -rf spec/jruby || die
+
+ sed -i -e 's/git ls-files -z/find * -print0/' msgpack.gemspec || die
+}