summaryrefslogtreecommitdiff
path: root/dev-ruby/msgpack/msgpack-1.6.1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-03-19 00:32:54 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-03-19 00:32:54 +0000
commit434fbe89e81a1fe06d92676be72ab7f862cc3f53 (patch)
tree7ed0f70fded2af7cbc43e42097f4cd2cebd8c845 /dev-ruby/msgpack/msgpack-1.6.1.ebuild
parentcd0d9000770337b445051f1852fe3971ceb7a6e2 (diff)
gentoo auto-resync : 19:03:2023 - 00:32:54
Diffstat (limited to 'dev-ruby/msgpack/msgpack-1.6.1.ebuild')
-rw-r--r--dev-ruby/msgpack/msgpack-1.6.1.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/dev-ruby/msgpack/msgpack-1.6.1.ebuild b/dev-ruby/msgpack/msgpack-1.6.1.ebuild
new file mode 100644
index 000000000000..b7184188713e
--- /dev/null
+++ b/dev-ruby/msgpack/msgpack-1.6.1.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+USE_RUBY="ruby27 ruby30 ruby31 ruby32"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec3"
+RUBY_FAKEGEM_EXTRADOC="ChangeLog README.md"
+RUBY_FAKEGEM_BINWRAP=""
+RUBY_FAKEGEM_EXTENSIONS=(ext/msgpack/extconf.rb)
+RUBY_FAKEGEM_EXTENSION_LIBDIR="lib/msgpack"
+RUBY_FAKEGEM_GEMSPEC="${PN}.gemspec"
+RUBY_S="${PN}-ruby-${PV}"
+inherit ruby-fakegem
+
+DESCRIPTION="Binary-based efficient data interchange format for ruby binding"
+HOMEPAGE="https://msgpack.org/"
+# In 1.6.1, they stopped shipping the specs in the gem :(
+# https://github.com/msgpack/msgpack-ruby/commit/9cbcd0b28527af5ca755f34dfb370e3f4474d129 (https://github.com/msgpack/msgpack-ruby/pull/311)
+SRC_URI="https://github.com/msgpack/msgpack-ruby/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ppc64 ~sparc ~x86"
+IUSE="doc"
+
+all_ruby_prepare() {
+ sed -i -e '/bundler/I s:^:#:' Rakefile || die
+
+ # Remove jruby-specific specs that are run also for other rubies.
+ rm -rf spec/jruby || die
+
+ sed -i -e 's/git ls-files/find * -print/' msgpack.gemspec || die
+}