summaryrefslogtreecommitdiff
path: root/dev-ruby/mixlib-shellout/mixlib-shellout-3.2.7.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-11-12 10:27:43 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-11-12 10:27:43 +0000
commitf1535b44d6fda761018ea432a180dcb482e97652 (patch)
tree0c17b546154f9b91340a45d84b5dc42dc12c7713 /dev-ruby/mixlib-shellout/mixlib-shellout-3.2.7.ebuild
parentcdc1eda9c1ad611dd737415be2790c8f44812f1c (diff)
gentoo auto-resync : 12:11:2023 - 10:27:42
Diffstat (limited to 'dev-ruby/mixlib-shellout/mixlib-shellout-3.2.7.ebuild')
-rw-r--r--dev-ruby/mixlib-shellout/mixlib-shellout-3.2.7.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/dev-ruby/mixlib-shellout/mixlib-shellout-3.2.7.ebuild b/dev-ruby/mixlib-shellout/mixlib-shellout-3.2.7.ebuild
new file mode 100644
index 000000000000..5c3ef41fe0bd
--- /dev/null
+++ b/dev-ruby/mixlib-shellout/mixlib-shellout-3.2.7.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+USE_RUBY="ruby31 ruby32"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec3"
+
+RUBY_FAKEGEM_EXTRA_DOC="CHANGELOG.md README.md"
+
+RUBY_FAKEGEM_GEMSPEC="mixlib-shellout.gemspec"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Run external commands on Unix or Windows"
+HOMEPAGE="https://github.com/chef/mixlib-shellout"
+SRC_URI="https://github.com/chef/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+ruby_add_rdepend "dev-ruby/chef-utils"
+
+each_ruby_prepare() {
+ # Make sure we actually use the right interpreter for testing
+ sed -i -e "/ruby_eval/ s:ruby :${RUBY} :" spec/mixlib/shellout_spec.rb || die
+
+ # Avoid spec that requires an interactive terminal
+ sed -e '/with subprocess writing lots of data to both stdout and stderr/,/^ end/ s:^:#:' \
+ -i spec/mixlib/shellout_spec.rb || die
+}