summaryrefslogtreecommitdiff
path: root/dev-ruby/minitest-around
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-06-02 21:45:28 +0100
committerV3n3RiX <venerix@redcorelinux.org>2019-06-02 21:45:28 +0100
commit2018227e9344edb9da15fc6a4a8298086cc2aa77 (patch)
treec18e1c09e605e94e2a1e93345ad25746cc9e14b9 /dev-ruby/minitest-around
parent6f8038813c460b4f0572d5ef595cdfa94af3a94d (diff)
gentoo resync : 02.06.2019
Diffstat (limited to 'dev-ruby/minitest-around')
-rw-r--r--dev-ruby/minitest-around/Manifest3
-rw-r--r--dev-ruby/minitest-around/metadata.xml11
-rw-r--r--dev-ruby/minitest-around/minitest-around-0.5.0.ebuild34
3 files changed, 48 insertions, 0 deletions
diff --git a/dev-ruby/minitest-around/Manifest b/dev-ruby/minitest-around/Manifest
new file mode 100644
index 000000000000..dd29a5528116
--- /dev/null
+++ b/dev-ruby/minitest-around/Manifest
@@ -0,0 +1,3 @@
+DIST minitest-around-0.5.0.gem 11776 BLAKE2B 1b1bacc229252e41412380d95e50ad05f918c13d37e7939f96fa19e4254c7f5222482d0f080355e5a900ff8ef89f768cc527c9b1c2644817e4d46842cbf83140 SHA512 8e57d436d39a41c5a08df6006a5cd46f92550844f01f9b6662918b9ba9536b74f6c83fcaea64180c7e025a1a14d4e037e1b17b84ae395a2b745e58f21ba5c752
+EBUILD minitest-around-0.5.0.ebuild 746 BLAKE2B 4225c1129b08b5f913b420e4a5719ad7999d03e590254dca6e0bebb3162cf025222d7bbd4200ce75eddc1bc0c2deb4879fbfe2959763f5a8509f85bca2e779ba SHA512 9686845dbef9db05d724939196c9eac6d288a23bd872348bb632d5b50779f5e051d0a84b3246e98fdb0793e2a0b0951ecea323dd42a498883317dd905c5bfa7f
+MISC metadata.xml 351 BLAKE2B ae5b0a952544183ccb7ea67c0481ea052d6188effaa70cf6e27b542a0beb738f8bf7c6c8fe77a14a398ff7c417a83247aa4415100dd1f6029d69b8e777f7a774 SHA512 31b2d93963f828730d17dcd8eb9bad905b6b06a4ea9442375a4de3af1906b925530cbe21608c12b7608c790cbd1743cf16ec8147151c8073d72798d903a6a05c
diff --git a/dev-ruby/minitest-around/metadata.xml b/dev-ruby/minitest-around/metadata.xml
new file mode 100644
index 000000000000..4cbe1280bf75
--- /dev/null
+++ b/dev-ruby/minitest-around/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>ruby@gentoo.org</email>
+ <name>Gentoo Ruby Project</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">splattael/minitest-around</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-ruby/minitest-around/minitest-around-0.5.0.ebuild b/dev-ruby/minitest-around/minitest-around-0.5.0.ebuild
new file mode 100644
index 000000000000..286620470fb8
--- /dev/null
+++ b/dev-ruby/minitest-around/minitest-around-0.5.0.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+USE_RUBY="ruby24 ruby25 ruby26"
+
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_EXTRADOC="README.md"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Alternative for setup/teardown dance"
+HOMEPAGE="https://github.com/splattael/minitest-around"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+ruby_add_rdepend "dev-ruby/minitest:5"
+
+ruby_add_bdepend "test? ( dev-ruby/bundler dev-util/cucumber )"
+
+all_ruby_prepare() {
+ sed -i -e '/bump/ s:^:#:' \
+ -e '/ls-files/d' \
+ -e '/cucumber/ s/,.*$//' minitest-around.gemspec Rakefile || die
+}
+
+each_ruby_test() {
+ for f in test/*_{test,spec}.rb ; do
+ ${RUBY} -S rake test:isolated TEST="${f}" || die
+ done
+}