summaryrefslogtreecommitdiff
path: root/dev-ruby/mime-types/mime-types-2.99.2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-ruby/mime-types/mime-types-2.99.2.ebuild
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-ruby/mime-types/mime-types-2.99.2.ebuild')
-rw-r--r--dev-ruby/mime-types/mime-types-2.99.2.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/dev-ruby/mime-types/mime-types-2.99.2.ebuild b/dev-ruby/mime-types/mime-types-2.99.2.ebuild
new file mode 100644
index 000000000000..43b96b1bc48d
--- /dev/null
+++ b/dev-ruby/mime-types/mime-types-2.99.2.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+USE_RUBY="ruby23 ruby24 ruby25"
+
+RUBY_FAKEGEM_RECIPE_DOC="rdoc"
+RUBY_FAKEGEM_EXTRADOC="History.rdoc History-Types.rdoc README.rdoc"
+
+RUBY_FAKEGEM_EXTRAINSTALL="data"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Provides a mailcap-like MIME Content-Type lookup for Ruby"
+HOMEPAGE="https://github.com/mime-types/ruby-mime-types"
+
+LICENSE="MIT Artistic GPL-2"
+SLOT="2"
+KEYWORDS="alpha amd64 arm ~arm64 ~hppa ia64 ppc ppc64 sparc x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE=""
+
+ruby_add_bdepend "test? ( dev-ruby/minitest:5 )"
+
+all_ruby_prepare() {
+ # Avoid unneeded dependency on minitest-focus.
+ sed -i -e '/focus/ s:^:#:' \
+ -e 's:fivemat/::' \
+ test/minitest_helper.rb || die
+}
+
+each_ruby_test() {
+ ${RUBY} -Ilib:test:. -e 'Dir["test/test_*.rb"].each{|f| require f}' || die
+}