summaryrefslogtreecommitdiff
path: root/dev-ruby/mime-types/mime-types-2.99.2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 20:57:42 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 20:57:42 +0100
commit1798c4aeca70ac8d0a243684d6a798fbc65735f8 (patch)
treee48e19cb6fa03de18e1c63e1a93371b7ebc4eb56 /dev-ruby/mime-types/mime-types-2.99.2.ebuild
parentd87262dd706fec50cd150aab3e93883b6337466d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-ruby/mime-types/mime-types-2.99.2.ebuild')
-rw-r--r--dev-ruby/mime-types/mime-types-2.99.2.ebuild34
1 files changed, 0 insertions, 34 deletions
diff --git a/dev-ruby/mime-types/mime-types-2.99.2.ebuild b/dev-ruby/mime-types/mime-types-2.99.2.ebuild
deleted file mode 100644
index 43b96b1bc48d..000000000000
--- a/dev-ruby/mime-types/mime-types-2.99.2.ebuild
+++ /dev/null
@@ -1,34 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-USE_RUBY="ruby23 ruby24 ruby25"
-
-RUBY_FAKEGEM_RECIPE_DOC="rdoc"
-RUBY_FAKEGEM_EXTRADOC="History.rdoc History-Types.rdoc README.rdoc"
-
-RUBY_FAKEGEM_EXTRAINSTALL="data"
-
-inherit ruby-fakegem
-
-DESCRIPTION="Provides a mailcap-like MIME Content-Type lookup for Ruby"
-HOMEPAGE="https://github.com/mime-types/ruby-mime-types"
-
-LICENSE="MIT Artistic GPL-2"
-SLOT="2"
-KEYWORDS="alpha amd64 arm ~arm64 ~hppa ia64 ppc ppc64 sparc x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
-IUSE=""
-
-ruby_add_bdepend "test? ( dev-ruby/minitest:5 )"
-
-all_ruby_prepare() {
- # Avoid unneeded dependency on minitest-focus.
- sed -i -e '/focus/ s:^:#:' \
- -e 's:fivemat/::' \
- test/minitest_helper.rb || die
-}
-
-each_ruby_test() {
- ${RUBY} -Ilib:test:. -e 'Dir["test/test_*.rb"].each{|f| require f}' || die
-}