summaryrefslogtreecommitdiff
path: root/dev-ruby/metasploit_payloads-mettle
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-ruby/metasploit_payloads-mettle
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-ruby/metasploit_payloads-mettle')
-rw-r--r--dev-ruby/metasploit_payloads-mettle/Manifest3
-rw-r--r--dev-ruby/metasploit_payloads-mettle/metadata.xml12
-rw-r--r--dev-ruby/metasploit_payloads-mettle/metasploit_payloads-mettle-0.1.9.ebuild49
3 files changed, 64 insertions, 0 deletions
diff --git a/dev-ruby/metasploit_payloads-mettle/Manifest b/dev-ruby/metasploit_payloads-mettle/Manifest
new file mode 100644
index 000000000000..64527e3c1dc4
--- /dev/null
+++ b/dev-ruby/metasploit_payloads-mettle/Manifest
@@ -0,0 +1,3 @@
+DIST metasploit_payloads-mettle-0.1.9.gem 8368640 BLAKE2B c42ac3a1651e75c0ca313b19bb40151cb78f27057096bde70cc96ed571745466da46dffdacb9b6f64c25377447626624427db74251e7a65302e76ccddb6b594c SHA512 75573a3156551a47a6a826166d0964a0e4addff4c0fde60fb44b2fa078357153ed4e64813d4639e64e92523cb946c8b2e2153e3fc10021733482b1a083be983a
+EBUILD metasploit_payloads-mettle-0.1.9.ebuild 1684 BLAKE2B 0c4b77a26249afa661f83691016133e22d1716a080bd7757d57a5ee618a625a05cad56188135a19ffb81b868a001ab477e79b03cc2a20b865c5fc5515aaa2aa7 SHA512 8728c3103983bc6f561a5555ccfa0b9ecf666e2951f73ecd35d9eef830fc092b7cf122b0ce14b989dd0f2192936285bca57f1f13cd8ad9096e18c7cb56d66a97
+MISC metadata.xml 405 BLAKE2B 90dfb31afea9cdd11f6a76d3492227e82af8ed09b2cb977c0d885a93eeb729b2601a27544459573681302221ee8d1a645037fd4de609dc95a11e3d84f32d51ad SHA512 fefa2f08d4ee78ae1d3d057588d8c015c6133c3231f0dc3ea0be3ec080114fc9227684a6e268a2ceabe88f6bc0360088b6aecff54346ac5f5f5d45e13504c2c0
diff --git a/dev-ruby/metasploit_payloads-mettle/metadata.xml b/dev-ruby/metasploit_payloads-mettle/metadata.xml
new file mode 100644
index 000000000000..af9237fca3f1
--- /dev/null
+++ b/dev-ruby/metasploit_payloads-mettle/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>zerochaos@gentoo.org</email>
+ <name>Rick Farina</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">rapid7/mettle</remote-id>
+ <remote-id type="rubygems">metasploit_payloads-mettle</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-ruby/metasploit_payloads-mettle/metasploit_payloads-mettle-0.1.9.ebuild b/dev-ruby/metasploit_payloads-mettle/metasploit_payloads-mettle-0.1.9.ebuild
new file mode 100644
index 000000000000..bbe49b6aebf2
--- /dev/null
+++ b/dev-ruby/metasploit_payloads-mettle/metasploit_payloads-mettle-0.1.9.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+USE_RUBY="ruby21 ruby22 ruby23"
+
+RUBY_FAKEGEM_TASK_DOC=""
+
+RUBY_FAKEGEM_EXTRAINSTALL="build"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Compiled binaries for Metasploit's next-gen Meterpreter"
+HOMEPAGE="https://rubygems.org/gems/metasploit_payloads-mettle"
+
+LICENSE="BSD"
+
+SLOT="${PV}"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE=""
+
+#no tests
+RESTRICT="test strip"
+
+QA_PREBUILT="
+ usr/lib*/ruby/gems/*/gems/${P}/build/mips-linux-muslsf/bin/mettle.bin
+ usr/lib*/ruby/gems/*/gems/${P}/build/mips64-linux-muslsf/bin/mettle.bin
+ usr/lib*/ruby/gems/*/gems/${P}/build/aarch64-linux-musl/bin/mettle.bin
+ usr/lib*/ruby/gems/*/gems/${P}/build/armv5b-linux-musleabi/bin/mettle.bin
+ usr/lib*/ruby/gems/*/gems/${P}/build/armv5l-linux-musleabi/bin/mettle.bin
+ usr/lib*/ruby/gems/*/gems/${P}/build/i486-linux-musl/bin/mettle.bin
+ usr/lib*/ruby/gems/*/gems/${P}/build/mipsel-linux-muslsf/bin/mettle.bin
+ usr/lib*/ruby/gems/*/gems/${P}/build/powerpc-linux-muslsf/bin/mettle.bin
+ usr/lib*/ruby/gems/*/gems/${P}/build/powerpc64le-linux-musl/bin/mettle.bin
+ usr/lib*/ruby/gems/*/gems/${P}/build/x86_64-linux-musl/bin/mettle.bin
+ usr/lib*/ruby/gems/*/gems/${P}/build/s390x-linux-musl/bin/mettle
+ usr/lib*/ruby/gems/*/gems/${P}/build/s390x-linux-musl/bin/mettle.bin
+ "
+
+src_install() {
+ ruby-ng_src_install
+ #tell revdep-rebuild to ignore binaries meant for the target
+ dodir /etc/revdep-rebuild
+ cat <<-EOF > "${ED}"/etc/revdep-rebuild/99-${PN}-${SLOT} || die
+ #These dirs contain prebuilt binaries for running on the TARGET not the HOST
+ SEARCH_DIRS_MASK="/usr/lib*/ruby/gems/*/gems/${P}/build"
+ EOF
+}