summaryrefslogtreecommitdiff
path: root/dev-ruby/metasploit-payloads
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-ruby/metasploit-payloads
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-ruby/metasploit-payloads')
-rw-r--r--dev-ruby/metasploit-payloads/Manifest5
-rw-r--r--dev-ruby/metasploit-payloads/metadata.xml12
-rw-r--r--dev-ruby/metasploit-payloads/metasploit-payloads-1.2.24.ebuild44
-rw-r--r--dev-ruby/metasploit-payloads/metasploit-payloads-1.2.28.ebuild44
4 files changed, 105 insertions, 0 deletions
diff --git a/dev-ruby/metasploit-payloads/Manifest b/dev-ruby/metasploit-payloads/Manifest
new file mode 100644
index 000000000000..08f9b3a0542b
--- /dev/null
+++ b/dev-ruby/metasploit-payloads/Manifest
@@ -0,0 +1,5 @@
+DIST metasploit-payloads-1.2.24.gem 13022720 BLAKE2B 4e28598ca5934e44009179e792d80dc7b580a69d4e2579d1d03a06eed9571a935607bc7949737cea053ddf7371a46ecbe5906e3e9c7f1486347bc8e7cb56294e SHA512 d27072c039b8cd6b438417d1c3fccc1c4559b82c07101ee90dfdb74c958861e57113e73a2351ac2a73ab36fe2b3157319910d8743363cdbcdedc5117636fd982
+DIST metasploit-payloads-1.2.28.gem 11547648 BLAKE2B e3511386c271c4925becd844dcf58d679eea3745249bb875cb557334c71ad0154de6908994e1e0bfaab69aba457eb8e31650d23111576829d90dc3ba82ff7426 SHA512 73a392df7f2eb082099da2017357d6a3231ee6266781d94be37067cf86c9b8e21d91b5cfdb1f810728a42dc748a9c4729d5f97926a88547af8d658e105a5dcb5
+EBUILD metasploit-payloads-1.2.24.ebuild 1392 BLAKE2B f19956df1f960268ba7aa8abd27f71955adf6f684a53064188574d57009579bb382408ac8c79f1d1b7f13ff7d09a975ea5e98d7d5f071258295c957fab2f3cf1 SHA512 c41c9d1479a6d9cfcbb460bc8da8511cfbb9ab907d1d39bf155bda1ce73001598e4e45e3fe6ffd9a910e1dae426390f2eca350e1caf898c3954d6d2fc17915d2
+EBUILD metasploit-payloads-1.2.28.ebuild 1392 BLAKE2B f19956df1f960268ba7aa8abd27f71955adf6f684a53064188574d57009579bb382408ac8c79f1d1b7f13ff7d09a975ea5e98d7d5f071258295c957fab2f3cf1 SHA512 c41c9d1479a6d9cfcbb460bc8da8511cfbb9ab907d1d39bf155bda1ce73001598e4e45e3fe6ffd9a910e1dae426390f2eca350e1caf898c3954d6d2fc17915d2
+MISC metadata.xml 411 BLAKE2B 1c2147ca1973736e6f07ec50fe8c6cb2d1a09139c34e7fa7cfb92b79f63df8e78998755f3ec257247fcd33ef555c70bdfbc7940baee4b6f035c65c89c6752697 SHA512 743c8818374b6225188a44bb6ef3eaf340911620ff58c338a2f361d71a98256746de45e6e141d45e43d79a3fc5967cc9565e3b415bcea63044cd6b898107093d
diff --git a/dev-ruby/metasploit-payloads/metadata.xml b/dev-ruby/metasploit-payloads/metadata.xml
new file mode 100644
index 000000000000..a08ccf4f3665
--- /dev/null
+++ b/dev-ruby/metasploit-payloads/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>zerochaos@gentoo.org</email>
+ <name>Rick Farina</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">rapid7/metasploit-payloads</remote-id>
+ <remote-id type="rubygems">metasploit-payloads</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-ruby/metasploit-payloads/metasploit-payloads-1.2.24.ebuild b/dev-ruby/metasploit-payloads/metasploit-payloads-1.2.24.ebuild
new file mode 100644
index 000000000000..a918c8a6c417
--- /dev/null
+++ b/dev-ruby/metasploit-payloads/metasploit-payloads-1.2.24.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+USE_RUBY="ruby21 ruby22 ruby23"
+
+RUBY_FAKEGEM_TASK_DOC=""
+
+RUBY_FAKEGEM_EXTRAINSTALL="data"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Compiled binaries for Metasploit's Meterpreter"
+HOMEPAGE="https://rubygems.org/gems/metasploit-payloads"
+
+LICENSE="BSD"
+
+SLOT="${PV}"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE=""
+
+#no tests
+RESTRICT="test strip"
+
+QA_PREBUILT="
+ usr/lib*/ruby/gems/*/gems/${PN}-${SLOT}/data/meterpreter/msflinker_linux_x86.bin
+ usr/lib*/ruby/gems/*/gems/${PN}-${SLOT}/data/meterpreter/ext_server_sniffer.lso
+ usr/lib*/ruby/gems/*/gems/${PN}-${SLOT}/data/meterpreter/ext_server_networkpug.lso
+ usr/lib*/ruby/gems/*/gems/${PN}-${SLOT}/data/meterpreter/ext_server_stdapi.lso
+ usr/lib*/ruby/gems/*/gems/${PN}-${SLOT}/data/android/libs/armeabi/libndkstager.so
+ usr/lib*/ruby/gems/*/gems/${PN}-${SLOT}/data/android/libs/mips/libndkstager.so
+ usr/lib*/ruby/gems/*/gems/${PN}-${SLOT}/data/android/libs/x86/libndkstager.so
+ "
+
+src_install() {
+ ruby-ng_src_install
+ #tell revdep-rebuild to ignore binaries meant for the target
+ dodir /etc/revdep-rebuild
+ cat <<-EOF > "${ED}"/etc/revdep-rebuild/99-${PN}-${SLOT} || die
+ #These dirs contain prebuilt binaries for running on the TARGET not the HOST
+ SEARCH_DIRS_MASK="/usr/lib*/ruby/gems/*/gems/${PN}-${SLOT}/data/android/libs"
+ EOF
+}
diff --git a/dev-ruby/metasploit-payloads/metasploit-payloads-1.2.28.ebuild b/dev-ruby/metasploit-payloads/metasploit-payloads-1.2.28.ebuild
new file mode 100644
index 000000000000..a918c8a6c417
--- /dev/null
+++ b/dev-ruby/metasploit-payloads/metasploit-payloads-1.2.28.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+USE_RUBY="ruby21 ruby22 ruby23"
+
+RUBY_FAKEGEM_TASK_DOC=""
+
+RUBY_FAKEGEM_EXTRAINSTALL="data"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Compiled binaries for Metasploit's Meterpreter"
+HOMEPAGE="https://rubygems.org/gems/metasploit-payloads"
+
+LICENSE="BSD"
+
+SLOT="${PV}"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE=""
+
+#no tests
+RESTRICT="test strip"
+
+QA_PREBUILT="
+ usr/lib*/ruby/gems/*/gems/${PN}-${SLOT}/data/meterpreter/msflinker_linux_x86.bin
+ usr/lib*/ruby/gems/*/gems/${PN}-${SLOT}/data/meterpreter/ext_server_sniffer.lso
+ usr/lib*/ruby/gems/*/gems/${PN}-${SLOT}/data/meterpreter/ext_server_networkpug.lso
+ usr/lib*/ruby/gems/*/gems/${PN}-${SLOT}/data/meterpreter/ext_server_stdapi.lso
+ usr/lib*/ruby/gems/*/gems/${PN}-${SLOT}/data/android/libs/armeabi/libndkstager.so
+ usr/lib*/ruby/gems/*/gems/${PN}-${SLOT}/data/android/libs/mips/libndkstager.so
+ usr/lib*/ruby/gems/*/gems/${PN}-${SLOT}/data/android/libs/x86/libndkstager.so
+ "
+
+src_install() {
+ ruby-ng_src_install
+ #tell revdep-rebuild to ignore binaries meant for the target
+ dodir /etc/revdep-rebuild
+ cat <<-EOF > "${ED}"/etc/revdep-rebuild/99-${PN}-${SLOT} || die
+ #These dirs contain prebuilt binaries for running on the TARGET not the HOST
+ SEARCH_DIRS_MASK="/usr/lib*/ruby/gems/*/gems/${PN}-${SLOT}/data/android/libs"
+ EOF
+}