summaryrefslogtreecommitdiff
path: root/dev-ruby/maxitest/maxitest-3.7.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-04-07 05:29:14 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-04-07 05:29:14 +0100
commitefbb52742172c497c5245486906aade0fb6220e8 (patch)
treed5c0f732886622336af2aef18c532c92eb979ba2 /dev-ruby/maxitest/maxitest-3.7.0.ebuild
parent91f19a3f41e80c4ab434a07636edb90912ef7556 (diff)
gentoo auto-resync : 07:04:2023 - 05:29:14
Diffstat (limited to 'dev-ruby/maxitest/maxitest-3.7.0.ebuild')
-rw-r--r--dev-ruby/maxitest/maxitest-3.7.0.ebuild50
1 files changed, 0 insertions, 50 deletions
diff --git a/dev-ruby/maxitest/maxitest-3.7.0.ebuild b/dev-ruby/maxitest/maxitest-3.7.0.ebuild
deleted file mode 100644
index 5be938ace85c..000000000000
--- a/dev-ruby/maxitest/maxitest-3.7.0.ebuild
+++ /dev/null
@@ -1,50 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-USE_RUBY="ruby26 ruby27 ruby30"
-
-RUBY_FAKEGEM_EXTRADOC="Readme.md"
-
-RUBY_FAKEGEM_RECIPE_TEST="rspec3"
-
-RUBY_FAKEGEM_GEMSPEC="${PN}.gemspec"
-
-inherit ruby-fakegem
-
-DESCRIPTION="Minitest + all the features you always wanted"
-HOMEPAGE="https://github.com/grosser/maxitest"
-SRC_URI="https://github.com/grosser/maxitest/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="1"
-KEYWORDS="amd64 arm ~arm64 ~hppa ppc ppc64 ~riscv ~sparc x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
-IUSE=""
-
-ruby_add_rdepend "<dev-ruby/minitest-5.15:5"
-
-ruby_add_bdepend "test? ( dev-ruby/bundler )"
-
-all_ruby_prepare() {
- rm -f Gemfile.lock || die
- # Remove developer-only gems from the gemspec and avoid git issues
- sed -i -e '/wwtd/ s:^:#:' \
- -e 's/git ls-files/find */' \
- ${RUBY_FAKEGEM_GEMSPEC} || die
- sed -i -e '/\(byebug\|bump\)/ s:^:#:' Gemfile || die
-
- sed -e '/shows short backtraces/askip "fails on ruby27"' \
- -e '/fails when not used/askip "fails with newer maxitest by design"' \
- -i spec/maxitest_spec.rb || die
-}
-
-each_ruby_prepare() {
- # Use the correct target
- sed -i -e '/sh/ s:ruby:'${RUBY}':' \
- -e '/sh/ s:mtest:'${RUBY}' -S mtest:' \
- spec/maxitest_spec.rb || die
-}
-
-each_ruby_test() {
- PATH="${S}/bin:${PATH}" RSPEC_VERSION=3 ruby-ng_rspec spec
-}