summaryrefslogtreecommitdiff
path: root/dev-ruby/maruku/maruku-0.7.3.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /dev-ruby/maruku/maruku-0.7.3.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'dev-ruby/maruku/maruku-0.7.3.ebuild')
-rw-r--r--dev-ruby/maruku/maruku-0.7.3.ebuild42
1 files changed, 42 insertions, 0 deletions
diff --git a/dev-ruby/maruku/maruku-0.7.3.ebuild b/dev-ruby/maruku/maruku-0.7.3.ebuild
new file mode 100644
index 000000000000..214a9ea887d0
--- /dev/null
+++ b/dev-ruby/maruku/maruku-0.7.3.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+USE_RUBY="ruby22 ruby23 ruby24"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec3"
+
+RUBY_FAKEGEM_RECIPE_DOC="rdoc"
+RUBY_FAKEGEM_DOCDIR="doc"
+RUBY_FAKEGEM_EXTRADOC="docs/div_syntax.md docs/entity_test.md
+ docs/markdown_syntax.md docs/maruku.md docs/math.md docs/other_stuff.md
+ docs/proposal.md"
+RUBY_FAKEGEM_EXTRAINSTALL="data"
+
+inherit ruby-fakegem
+
+DESCRIPTION="A Markdown-superset interpreter written in Ruby"
+HOMEPAGE="https://github.com/bhollis/maruku"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~x86 ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="highlight test"
+
+ruby_add_bdepend "test? ( dev-ruby/nokogiri-diff )"
+ruby_add_rdepend "highlight? ( dev-ruby/syntax )"
+
+DEPEND+=" test? ( app-text/blahtexml )"
+
+all_ruby_prepare() {
+ sed -i -e '/[Ss]imple[Cc]ov/ s:^:#:' spec/spec_helper.rb || die
+}
+
+pkg_postinst() {
+ elog
+ elog "You need to emerge app-text/texlive and dev-texlive/texlive-latexextra if"
+ elog "you want to use --pdf with Maruku. You may also want to emerge"
+ elog "dev-texlive/texlive-latexrecommended to enable LaTeX syntax highlighting."
+ elog
+}