summaryrefslogtreecommitdiff
path: root/dev-ruby/maildir/maildir-2.2.3.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-06-29 11:38:31 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-06-29 11:38:31 +0100
commit90c88731bd036e5698b281fbc0a5f3aa4c9983ac (patch)
tree83fc5facb6b12be510a37bc3d241cc63e965b13a /dev-ruby/maildir/maildir-2.2.3.ebuild
parentfeb0daf81d888e9160f9f94502de09b66f2a63fd (diff)
gentoo resync : 29.06.2020
Diffstat (limited to 'dev-ruby/maildir/maildir-2.2.3.ebuild')
-rw-r--r--dev-ruby/maildir/maildir-2.2.3.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/dev-ruby/maildir/maildir-2.2.3.ebuild b/dev-ruby/maildir/maildir-2.2.3.ebuild
new file mode 100644
index 000000000000..5e034bb678bd
--- /dev/null
+++ b/dev-ruby/maildir/maildir-2.2.3.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+USE_RUBY="ruby25 ruby26 ruby27"
+
+RUBY_FAKEGEM_EXTRAINSTALL="README.rdoc"
+
+RUBY_FAKEGEM_BINWRAP=""
+
+inherit ruby-fakegem
+
+DESCRIPTION="A library for reading and writing arbitrary messages in DJB's maildir format"
+HOMEPAGE="https://github.com/ktheory/maildir"
+LICENSE="MIT"
+
+KEYWORDS="~amd64"
+SLOT="2"
+IUSE="test"
+
+ruby_add_bdepend "
+ test? ( >=dev-ruby/fakefs-0.3.2 dev-ruby/mail dev-ruby/shoulda-context dev-ruby/test-unit:2 )"
+
+all_ruby_prepare() {
+ sed -i -e '/bundler/ s:^:#:' Rakefile test/helper.rb || die
+ sed -i -e 's/shoulda/shoulda-context/' test/helper.rb || die
+
+ # Avoid tests that appear to need activesupport for .blank? support
+ sed -i -e '/add and remove flags/,/^ end/ s:^:#:' test/test_message.rb || die
+ sed -i -e '/be removed from flag list/,/^ end/ s:^:#:' test/test_maildir.rb || die
+}