summaryrefslogtreecommitdiff
path: root/dev-ruby/launchy/launchy-2.4.3-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /dev-ruby/launchy/launchy-2.4.3-r1.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'dev-ruby/launchy/launchy-2.4.3-r1.ebuild')
-rw-r--r--dev-ruby/launchy/launchy-2.4.3-r1.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/dev-ruby/launchy/launchy-2.4.3-r1.ebuild b/dev-ruby/launchy/launchy-2.4.3-r1.ebuild
new file mode 100644
index 000000000000..1b48d8eb6b36
--- /dev/null
+++ b/dev-ruby/launchy/launchy-2.4.3-r1.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+USE_RUBY="ruby20 ruby21 ruby22 ruby23"
+
+RUBY_FAKEGEM_EXTRADOC="README.md HISTORY.md"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Helper class for launching cross-platform applications"
+HOMEPAGE="https://github.com/copiousfreetime/launchy"
+
+LICENSE="ISC"
+
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+# File collision conflict with x11-misc/launchy, bug 545170
+ruby_add_rdepend ">=dev-ruby/addressable-2.3 !!x11-misc/launchy"
+
+ruby_add_bdepend "test? ( >=dev-ruby/minitest-5.0:5 )"
+
+# This test is expected to fail on linux, drop it
+RUBY_PATCHES=( "${FILESDIR}"/${PN}-2.4.2-drop-failing-test.patch )
+
+all_ruby_prepare() {
+ sed -i -e "/[Ss]implecov/d" spec/spec_helper.rb || die
+
+ # Avoid tests depending on the current user's desktop environment.
+ sed -e '/returns NotFound if it cannot determine/askip "gentoo"' \
+ -i spec/detect/nix_desktop_environment_spec.rb || die
+ sed -e '/asssumes we open a local file if we have an exception/askip "gentoo"' \
+ -i spec/launchy_spec.rb || die
+}