summaryrefslogtreecommitdiff
path: root/dev-ruby/jwt/jwt-2.7.1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-06-12 08:19:18 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-06-12 08:19:18 +0100
commit4d0ca679fbcb59301ffc7af98794c411c5061a0b (patch)
tree8353718f79e0de6c7c5ee2d6cab498bd3bebf565 /dev-ruby/jwt/jwt-2.7.1.ebuild
parent683e8a42fb208dee0d6289d084fb39ab17aa2b60 (diff)
gentoo auto-resync : 12:06:2023 - 08:19:18
Diffstat (limited to 'dev-ruby/jwt/jwt-2.7.1.ebuild')
-rw-r--r--dev-ruby/jwt/jwt-2.7.1.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/dev-ruby/jwt/jwt-2.7.1.ebuild b/dev-ruby/jwt/jwt-2.7.1.ebuild
new file mode 100644
index 000000000000..c713d5f1b367
--- /dev/null
+++ b/dev-ruby/jwt/jwt-2.7.1.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+USE_RUBY="ruby30 ruby31 ruby32"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec3"
+
+RUBY_FAKEGEM_BINWRAP=""
+RUBY_FAKEGEM_GEMSPEC="ruby-jwt.gemspec"
+
+inherit ruby-fakegem
+
+DESCRIPTION="A Ruby implementation of JSON Web Token draft 06"
+HOMEPAGE="https://github.com/jwt/ruby-jwt"
+SRC_URI="https://github.com/jwt/ruby-jwt/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="2"
+KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86"
+IUSE=""
+
+RUBY_S="ruby-jwt-${PV}"
+
+ruby_add_bdepend "test? ( dev-ruby/rbnacl )"
+
+all_ruby_prepare() {
+ sed -i -e "/simplecov/ s:^:#:" \
+ -e '/^SimpleCov.start/,/^end/ s:^:#:' \
+ spec/spec_helper.rb || die
+
+ sed -i -e 's/git ls-files -z/find * -print0/' ${RUBY_FAKEGEM_GEMSPEC} || die
+}