summaryrefslogtreecommitdiff
path: root/dev-ruby/json_schema/json_schema-0.20.8.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-09-15 09:01:56 +0100
committerV3n3RiX <venerix@redcorelinux.org>2019-09-15 09:01:56 +0100
commite8f81810baa21f490d6910e8e2d424546b72a333 (patch)
treedb79151c528a566490ffcac0d7b64484e12b4762 /dev-ruby/json_schema/json_schema-0.20.8.ebuild
parentd00821e77f72d4af4ea30158c1c6e18ffff0875b (diff)
gentoo resync : 15.09.2019
Diffstat (limited to 'dev-ruby/json_schema/json_schema-0.20.8.ebuild')
-rw-r--r--dev-ruby/json_schema/json_schema-0.20.8.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/dev-ruby/json_schema/json_schema-0.20.8.ebuild b/dev-ruby/json_schema/json_schema-0.20.8.ebuild
new file mode 100644
index 000000000000..494c6484e434
--- /dev/null
+++ b/dev-ruby/json_schema/json_schema-0.20.8.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+USE_RUBY="ruby24 ruby25 ruby26"
+
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG README.md TODO.md"
+
+RUBY_FAKEGEM_EXTRAINSTALL="schemas"
+
+RUBY_FAKEGEM_GEMSPEC="json_schema.gemspec"
+
+inherit ruby-fakegem
+
+DESCRIPTION="A JSON Schema V4 and Hyperschema V4 parser and validator"
+HOMEPAGE="https://github.com/brandur/json_schema"
+SRC_URI="https://github.com/brandur/json_schema/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+all_ruby_prepare() {
+ sed -i -e '/^if/,/^end/ s:^:#:' test/test_helper.rb || die
+}