summaryrefslogtreecommitdiff
path: root/dev-ruby/json
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-02-13 21:41:11 +0000
committerV3n3RiX <venerix@redcorelinux.org>2021-02-13 21:41:11 +0000
commitc8d60dada2ec8eb48b2d2b290cd6683ccec40e39 (patch)
treec44943ee0563a3fa957716de909fed683117fcb9 /dev-ruby/json
parent69051588e2f955485fe5d45d45e616bc60a2de57 (diff)
gentoo (valentine's day) resync : 14.02.2021
Diffstat (limited to 'dev-ruby/json')
-rw-r--r--dev-ruby/json/Manifest1
-rw-r--r--dev-ruby/json/json-2.5.1-r1.ebuild63
2 files changed, 64 insertions, 0 deletions
diff --git a/dev-ruby/json/Manifest b/dev-ruby/json/Manifest
index a12233997c90..249d92430385 100644
--- a/dev-ruby/json/Manifest
+++ b/dev-ruby/json/Manifest
@@ -3,5 +3,6 @@ DIST json-2.3.1.gem 118784 BLAKE2B 6852f5d1733fd5d596b44d095c37d11a129b02fc61dc8
DIST json-2.5.1.tar.gz 131183 BLAKE2B 2ccdf5921ef476b66cb1dbf72cc01763636c82b0eb5d0a5cfc029e14177c7c6766464e7852b11c2424db401f5b931cb64c01d3952929236c9979378a7928ea59 SHA512 4df7ec9b86692376e89c2019c2c1ab3ae9af28fb4742864acc6f985c0551fc10795742cc1124d6435e820617c00d4c5f4aa6c83b21d2fff43ed05cd9d0a89087
EBUILD json-2.3.0.ebuild 2009 BLAKE2B d36aea49d26a9560c3dc178143932411969c63fe353f13230357e18a10103e04c61d657483059f62df79d9ca0bad8c8c8f5063bc96ae701b7722b006b18fa249 SHA512 552c9cc17d79bc8b16b6e6eb2c4d6d6bb561a8f200c3706faecbd0b43715f60ed63e52bbc8ee915a88328fba5db2bc5afe3443bea4e90d693c34638ab5227f20
EBUILD json-2.3.1.ebuild 2011 BLAKE2B c84cc2365edb9c5d5bdbe10e685633bd6686d2010b251bae57cb1b0eb03ffe1f2836dee1d3709d0f28d34c5f92ef46aac6b88603e1420baa05cc961b30fd4771 SHA512 2365221d5f20d97fec7f091ceaa4b5629f3caf8fc1e2f2000cae41815c13ea889fe0ad8430e17605d737576cc95bf98c4a2415cc753be9ba6220d3d92f31f419
+EBUILD json-2.5.1-r1.ebuild 1943 BLAKE2B 8b8d2e04bd4d491ddd3bee215c6843412029f03c856755733d07991af3afc5dab4bfa37816bd46e3c5ced33381cf172b90258bfd1565ab1ab8eedba85637f0f6 SHA512 29d35ed79592bd409ea5eb63078ae6a8704b0724174fe9377ae4793b06f56b661378268fd1a13dbe7b3d90558f693e6cf8c652dd15ee3e6a9343a10db92ec6bc
EBUILD json-2.5.1.ebuild 1995 BLAKE2B 74ca3a0ad79c798925abb2ccf15d0f57284ad7e3c2909b3680695f75cffe8326a7f15ca1673edb6c78a261da946692f21b54a263c1ce778656d1b90aacdca05f SHA512 1905491e97d2672b588e0ed8bc45a89eea6e0798121d3626f81a440dd4447a324b085f1d13b1baed51be7a6fea15bae71387cc0f82bf7ef9e426e342aaf423b1
MISC metadata.xml 336 BLAKE2B e1094160e19b252f7b3233dbd2006c889c0a02aa4b04063caeb7ded80bb2f08a2c4bc31cfb7bdc17398b8d1b8c3fc9f3600eafad9920fe0355c807d3899f794f SHA512 8b4fa7ef9b753bbf1206b1f8a796d3f3b8e3f9ca07906a2e01dbcc8c69d4cb5e5cb26c395d0676b4dedd70fb910cf0abd3be83d3c94f0b90aee87ea6fda12877
diff --git a/dev-ruby/json/json-2.5.1-r1.ebuild b/dev-ruby/json/json-2.5.1-r1.ebuild
new file mode 100644
index 000000000000..ee4ed3bbb0f4
--- /dev/null
+++ b/dev-ruby/json/json-2.5.1-r1.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+USE_RUBY="ruby25 ruby26 ruby27 ruby30"
+
+RUBY_FAKEGEM_EXTRADOC="CHANGES.md README.md"
+RUBY_FAKEGEM_DOCDIR="doc"
+
+RUBY_FAKEGEM_GEMSPEC="json.gemspec"
+
+RUBY_FAKEGEM_EXTENSIONS=(ext/json/ext/parser/extconf.rb ext/json/ext/generator/extconf.rb)
+
+inherit multilib ruby-fakegem
+
+DESCRIPTION="A JSON implementation as a Ruby extension"
+HOMEPAGE="https://github.com/flori/json"
+SRC_URI="https://github.com/flori/json/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+LICENSE="Ruby"
+
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+SLOT="2"
+IUSE=""
+
+RDEPEND="${RDEPEND}"
+DEPEND="${DEPEND}
+ dev-util/ragel"
+
+ruby_add_bdepend "dev-ruby/rake
+ doc? ( dev-ruby/rdoc )
+ test? ( dev-ruby/test-unit:2 )"
+
+all_ruby_prepare() {
+ # Avoid building the extension twice!
+ # And use rdoc instead of sdoc which we don't have packaged
+ # And don't call git to list files. We're using the pregenerated spec anyway.
+ sed -i \
+ -e '/task :test/ s|:compile,||' \
+ -e 's| => :clean||' \
+ -e 's|sdoc|rdoc|' \
+ -e 's|`git ls-files`|""|' \
+ Rakefile || die "rakefile fix failed"
+
+ # Remove hardcoded and broken -O setting.
+ sed -i -e '/^ \(if\|unless\)/,/^ end/ s:^:#:' \
+ -e '/^unless/,/^end/ s:^:#:' ext/json/ext/*/extconf.rb || die
+
+ # Avoid setting gem since it will not be available yet when installing
+ sed -i -e '/gem/ s:^:#:' tests/test_helper.rb || die
+}
+
+#each_ruby_compile() {
+# for ext in parser generator ; do
+# cp ext/json/ext/${ext}/${ext}$(get_modname) ext/json/ext/ || die
+# done
+#}
+
+each_ruby_install() {
+ each_fakegem_install
+
+ #ruby_fakegem_newins ext/json/ext/generator$(get_modname) lib/json/ext/generator$(get_modname)
+ #ruby_fakegem_newins ext/json/ext/parser$(get_modname) lib/json/ext/parser$(get_modname)
+}