summaryrefslogtreecommitdiff
path: root/dev-ruby/journey
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-11-25 22:39:15 +0000
committerV3n3RiX <venerix@redcorelinux.org>2020-11-25 22:39:15 +0000
commitd934827bf44b7cfcf6711964418148fa60877668 (patch)
tree0625f358789b5e015e49db139cc1dbc9be00428f /dev-ruby/journey
parent2e34d110f164bf74d55fced27fe0000201b3eec5 (diff)
gentoo resync : 25.11.2020
Diffstat (limited to 'dev-ruby/journey')
-rw-r--r--dev-ruby/journey/Manifest4
-rw-r--r--dev-ruby/journey/files/journey-1.0.4-fix-tests.patch66
-rw-r--r--dev-ruby/journey/journey-1.0.4-r1.ebuild25
-rw-r--r--dev-ruby/journey/metadata.xml11
4 files changed, 0 insertions, 106 deletions
diff --git a/dev-ruby/journey/Manifest b/dev-ruby/journey/Manifest
deleted file mode 100644
index 94ae3f8435af..000000000000
--- a/dev-ruby/journey/Manifest
+++ /dev/null
@@ -1,4 +0,0 @@
-AUX journey-1.0.4-fix-tests.patch 2149 BLAKE2B 17693a10ad41b43d17541cd93a3f7485a60766bf5bfa9f96c9e1031db44cf9ce04f02f7e5aaa78de29241346d3707591ae15dbe17f268b90a482a6158962d2f6 SHA512 d4b34ed92f131e6e17f4af6d9be5ec743b6950f86ee724d32be67fe88b378cd8998c6551e78d6dc7b72b2911afbb14ec8ddad3be414694b86c696a39513a2857
-DIST journey-1.0.4.gem 28672 BLAKE2B fe78647c9f80ad4b9874eab9488cca199cd69d354e69f3f5b47b417452ca259790109d07a27c4c2d99778683d9264413399d4d7acd7eb4d8e78f7e37ccf2a8d7 SHA512 9e6a06da8b77f6efb9941c58f53254e8cf3a1ebb6f8261a66ef3fed9c21ff4e4a90567fee88507b8e2c1fecc0fbdf204a9d3c8473b671bbb4b8c6b9faa6f2a07
-EBUILD journey-1.0.4-r1.ebuild 640 BLAKE2B ee6448b4ff69130d8ecf70bf79804b2ab77bef34f12f6e31de8e5c72aff90025f058c95ca263849d1ed0f1be645db0c3e8f6c089b181e3281d524199447b2ff9 SHA512 2666c80ea88b6f604ac9ef65956152ad7811340bdf17329293651d9f96c04359dcd371bd4c125419fb2c3909d0f5c697518e15ca697d5de636df4382a3a50f8f
-MISC metadata.xml 339 BLAKE2B ccf9044fae8d836e4a60fa4bb0c95bd245b55a21dfcb7367e8a41c854f32c0bf3b65bff9a0ef625bb645063f84ad01cc2cc0a13a1f2cad4732e959fae7122e1d SHA512 482ceff436735ee12e21e9519a174803b5c035dfc31df0e25eacecd6186682ec9209f5bea95d3ec8263dace8cd64145daee26986dc10820bf99db2793f942f7a
diff --git a/dev-ruby/journey/files/journey-1.0.4-fix-tests.patch b/dev-ruby/journey/files/journey-1.0.4-fix-tests.patch
deleted file mode 100644
index f977172e6464..000000000000
--- a/dev-ruby/journey/files/journey-1.0.4-fix-tests.patch
+++ /dev/null
@@ -1,66 +0,0 @@
-From d836e960d9a20c4c5bc986630d2ba34a340959ea Mon Sep 17 00:00:00 2001
-From: Aaron Patterson <aaron.patterson@gmail.com>
-Date: Fri, 27 Jul 2012 11:20:58 -0700
-Subject: [PATCH] fix assertion calls
-
----
- test/path/test_pattern.rb | 22 +++++++++++-----------
- 1 file changed, 11 insertions(+), 11 deletions(-)
-
-diff --git a/test/path/test_pattern.rb b/test/path/test_pattern.rb
-index c684a0a..ec93471 100644
---- a/test/path/test_pattern.rb
-+++ b/test/path/test_pattern.rb
-@@ -85,9 +85,9 @@ def test_to_regexp_with_extended_group
- ["/", ".", "?"]
- )
- path = Pattern.new strexp
-- assert_match('/page/tender', path)
-- assert_match('/page/love', path)
-- refute_match('/page/loving', path)
-+ assert_match(path, '/page/tender')
-+ assert_match(path, '/page/love')
-+ refute_match(path, '/page/loving')
- end
-
- def test_optional_names
-@@ -108,8 +108,8 @@ def test_to_regexp_match_non_optional
- ["/", ".", "?"]
- )
- path = Pattern.new strexp
-- assert_match('/123', path)
-- refute_match('/', path)
-+ assert_match(path, '/123')
-+ refute_match(path, '/')
- end
-
- def test_to_regexp_with_group
-@@ -119,9 +119,9 @@ def test_to_regexp_with_group
- ["/", ".", "?"]
- )
- path = Pattern.new strexp
-- assert_match('/page/tender', path)
-- assert_match('/page/love', path)
-- refute_match('/page/loving', path)
-+ assert_match(path, '/page/tender')
-+ assert_match(path, '/page/love')
-+ refute_match(path, '/page/loving')
- end
-
- def test_ast_sets_regular_expressions
-@@ -186,9 +186,9 @@ def test_insensitive_regexp_with_group
- ["/", ".", "?"]
- )
- path = Pattern.new strexp
-- assert_match('/page/TENDER/aaron', path)
-- assert_match('/page/loVE/aaron', path)
-- refute_match('/page/loVE/AAron', path)
-+ assert_match(path, '/page/TENDER/aaron')
-+ assert_match(path, '/page/loVE/aaron')
-+ refute_match(path, '/page/loVE/AAron')
- end
-
- def test_to_regexp_with_strexp
---
-1.9.1
-
diff --git a/dev-ruby/journey/journey-1.0.4-r1.ebuild b/dev-ruby/journey/journey-1.0.4-r1.ebuild
deleted file mode 100644
index 1e510b67e67e..000000000000
--- a/dev-ruby/journey/journey-1.0.4-r1.ebuild
+++ /dev/null
@@ -1,25 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-USE_RUBY="ruby23 ruby24 ruby25 ruby26"
-
-RUBY_FAKEGEM_RECIPE_DOC="rdoc"
-
-RUBY_FAKEGEM_EXTRADOC="CHANGELOG.rdoc README.rdoc"
-
-inherit ruby-fakegem versionator
-
-DESCRIPTION="Journey is a router. It routes requests"
-HOMEPAGE="https://github.com/rails/journey"
-
-LICENSE="MIT"
-SLOT="$(get_version_component_range 1-2)"
-KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86 ~amd64-linux ~x64-macos ~x86-solaris"
-IUSE=""
-
-ruby_add_bdepend "test? ( dev-ruby/hoe
- dev-ruby/json
- dev-ruby/minitest )"
-
-RUBY_PATCHES=( "${FILESDIR}"/${P}-fix-tests.patch )
diff --git a/dev-ruby/journey/metadata.xml b/dev-ruby/journey/metadata.xml
deleted file mode 100644
index 16111db641b1..000000000000
--- a/dev-ruby/journey/metadata.xml
+++ /dev/null
@@ -1,11 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
-<pkgmetadata>
- <maintainer type="project">
- <email>ruby@gentoo.org</email>
- <name>Gentoo Ruby Project</name>
- </maintainer>
- <upstream>
- <remote-id type="github">rails/journey</remote-id>
- </upstream>
-</pkgmetadata>