summaryrefslogtreecommitdiff
path: root/dev-ruby/journey
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-ruby/journey
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-ruby/journey')
-rw-r--r--dev-ruby/journey/Manifest4
-rw-r--r--dev-ruby/journey/files/journey-1.0.4-fix-tests.patch66
-rw-r--r--dev-ruby/journey/journey-1.0.4-r1.ebuild25
-rw-r--r--dev-ruby/journey/metadata.xml11
4 files changed, 106 insertions, 0 deletions
diff --git a/dev-ruby/journey/Manifest b/dev-ruby/journey/Manifest
new file mode 100644
index 000000000000..282fea63369b
--- /dev/null
+++ b/dev-ruby/journey/Manifest
@@ -0,0 +1,4 @@
+AUX journey-1.0.4-fix-tests.patch 2149 BLAKE2B 17693a10ad41b43d17541cd93a3f7485a60766bf5bfa9f96c9e1031db44cf9ce04f02f7e5aaa78de29241346d3707591ae15dbe17f268b90a482a6158962d2f6 SHA512 d4b34ed92f131e6e17f4af6d9be5ec743b6950f86ee724d32be67fe88b378cd8998c6551e78d6dc7b72b2911afbb14ec8ddad3be414694b86c696a39513a2857
+DIST journey-1.0.4.gem 28672 BLAKE2B fe78647c9f80ad4b9874eab9488cca199cd69d354e69f3f5b47b417452ca259790109d07a27c4c2d99778683d9264413399d4d7acd7eb4d8e78f7e37ccf2a8d7 SHA512 9e6a06da8b77f6efb9941c58f53254e8cf3a1ebb6f8261a66ef3fed9c21ff4e4a90567fee88507b8e2c1fecc0fbdf204a9d3c8473b671bbb4b8c6b9faa6f2a07
+EBUILD journey-1.0.4-r1.ebuild 643 BLAKE2B bceb0774a518d5f80eb7dd089ceecc1a16f7312098051a110765e9a7f8c7f444cd0964f79cd6d5456607e34a52aa9200741a3b6a3d28b44e82d4d0c26ab296d4 SHA512 60a51c21cdb8a90dc9a1cdd1b2a7f1791eb02d9f52a1a1e513a9de7b40729bb99e9b4d2e6cb741fdc980d672c2290b2ba3036583e196eb05db33af952bb12ad7
+MISC metadata.xml 339 BLAKE2B ccf9044fae8d836e4a60fa4bb0c95bd245b55a21dfcb7367e8a41c854f32c0bf3b65bff9a0ef625bb645063f84ad01cc2cc0a13a1f2cad4732e959fae7122e1d SHA512 482ceff436735ee12e21e9519a174803b5c035dfc31df0e25eacecd6186682ec9209f5bea95d3ec8263dace8cd64145daee26986dc10820bf99db2793f942f7a
diff --git a/dev-ruby/journey/files/journey-1.0.4-fix-tests.patch b/dev-ruby/journey/files/journey-1.0.4-fix-tests.patch
new file mode 100644
index 000000000000..f977172e6464
--- /dev/null
+++ b/dev-ruby/journey/files/journey-1.0.4-fix-tests.patch
@@ -0,0 +1,66 @@
+From d836e960d9a20c4c5bc986630d2ba34a340959ea Mon Sep 17 00:00:00 2001
+From: Aaron Patterson <aaron.patterson@gmail.com>
+Date: Fri, 27 Jul 2012 11:20:58 -0700
+Subject: [PATCH] fix assertion calls
+
+---
+ test/path/test_pattern.rb | 22 +++++++++++-----------
+ 1 file changed, 11 insertions(+), 11 deletions(-)
+
+diff --git a/test/path/test_pattern.rb b/test/path/test_pattern.rb
+index c684a0a..ec93471 100644
+--- a/test/path/test_pattern.rb
++++ b/test/path/test_pattern.rb
+@@ -85,9 +85,9 @@ def test_to_regexp_with_extended_group
+ ["/", ".", "?"]
+ )
+ path = Pattern.new strexp
+- assert_match('/page/tender', path)
+- assert_match('/page/love', path)
+- refute_match('/page/loving', path)
++ assert_match(path, '/page/tender')
++ assert_match(path, '/page/love')
++ refute_match(path, '/page/loving')
+ end
+
+ def test_optional_names
+@@ -108,8 +108,8 @@ def test_to_regexp_match_non_optional
+ ["/", ".", "?"]
+ )
+ path = Pattern.new strexp
+- assert_match('/123', path)
+- refute_match('/', path)
++ assert_match(path, '/123')
++ refute_match(path, '/')
+ end
+
+ def test_to_regexp_with_group
+@@ -119,9 +119,9 @@ def test_to_regexp_with_group
+ ["/", ".", "?"]
+ )
+ path = Pattern.new strexp
+- assert_match('/page/tender', path)
+- assert_match('/page/love', path)
+- refute_match('/page/loving', path)
++ assert_match(path, '/page/tender')
++ assert_match(path, '/page/love')
++ refute_match(path, '/page/loving')
+ end
+
+ def test_ast_sets_regular_expressions
+@@ -186,9 +186,9 @@ def test_insensitive_regexp_with_group
+ ["/", ".", "?"]
+ )
+ path = Pattern.new strexp
+- assert_match('/page/TENDER/aaron', path)
+- assert_match('/page/loVE/aaron', path)
+- refute_match('/page/loVE/AAron', path)
++ assert_match(path, '/page/TENDER/aaron')
++ assert_match(path, '/page/loVE/aaron')
++ refute_match(path, '/page/loVE/AAron')
+ end
+
+ def test_to_regexp_with_strexp
+--
+1.9.1
+
diff --git a/dev-ruby/journey/journey-1.0.4-r1.ebuild b/dev-ruby/journey/journey-1.0.4-r1.ebuild
new file mode 100644
index 000000000000..c18b64e98d2b
--- /dev/null
+++ b/dev-ruby/journey/journey-1.0.4-r1.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+USE_RUBY="ruby22 ruby23 ruby24 ruby25"
+
+RUBY_FAKEGEM_RECIPE_DOC="rdoc"
+
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG.rdoc README.rdoc"
+
+inherit ruby-fakegem versionator
+
+DESCRIPTION="Journey is a router. It routes requests"
+HOMEPAGE="https://github.com/rails/journey"
+
+LICENSE="MIT"
+SLOT="$(get_version_component_range 1-2)"
+KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86 ~amd64-linux ~x64-macos ~x86-solaris"
+IUSE=""
+
+ruby_add_bdepend "test? ( dev-ruby/hoe
+ dev-ruby/json
+ dev-ruby/minitest )"
+
+RUBY_PATCHES=( "${FILESDIR}"/${P}-fix-tests.patch )
diff --git a/dev-ruby/journey/metadata.xml b/dev-ruby/journey/metadata.xml
new file mode 100644
index 000000000000..16111db641b1
--- /dev/null
+++ b/dev-ruby/journey/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>ruby@gentoo.org</email>
+ <name>Gentoo Ruby Project</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">rails/journey</remote-id>
+ </upstream>
+</pkgmetadata>